[SOLVED] CAF Portlet / WSD doesn't pass document

Hi everybody

I’m trying to make a small application with a CAF portlet where you have to fill in your surname, name, email and the name of a course you want to participate in.

For this I have made a Document Type: Enrollment which contains a document with these 4 strings.
After that I made a flow service: sendEnrollment, this first checks if there is any data using the pub.flow:debugLog for the field coursename. After the debugLog it should publish to the broker with pub.publish:publish.
I used this flow service to create a provider web service which in turn I used to create the portlet input fields.

Now when I run the portlet, my server.log returns a null value for the coursename, which I filled in on the portlet.
When I run the flow service locally and provide the data through the prompt screen it works fine.

How can I make sure the CAF portlet or the WSD (I don’t really know where the problem lies) passes the data I provide on the form.

As you can notice from my explanation I’m still very new to this software so any help is greatly appreciated.
If you need any more information please don’t hesitate to ask.

With kind regards and thanks in advance.

*Suddenly… it worked