SFDC Adapter Issue

Hi,

We are in process of setting up the SFDC connection to salesforce.com. The WSDL our enterprise is using is 27. We are using adapter version 7.1.1. In the documentation it is mentioned that the wsdl version supported is 23 only. We tried to connect to the salesforce.com server using the enterprise WSDL url with version 27 argument. But when to tried to create any adapter service it failed saying “Failed to run resourceDomainLookupValues”.

We changed the enterprise wsdl version argument in the url to 23 and reconnected and we are able to perform the operations fine.

But i want to know how to connect to a server using wsdl version 27 and using adapter only.

Thanks in advance

Hi All,

We’re planning for an upgrade of Salesforce adapter from 7.1.1 to 8.2. With the Salesforce Adapter 7.1.1, there are limitations on upsert/insert objects if there are more than 200 records.

Can someone please confirm if this limitation applies to the latest Salesforce adapter (v8.2) as well?

Thanks in advance,
Prakash

SFDC adapter 8.2 has new bulk services if you need to insert/update a lot of records. These services use the latest REST api. The old insert/upsert service will continue to have the limitations as set by Salesforce.com. The adapter service simply carries your data to the backend.