Serial to Concurrent Mode on Trigger

My production environment has a broker trigger enabled and processing serially. I would like for this trigger to process concurrently instead, so I made my changes in my development environment (serially>concurrently) and all is well. I attempt to deploy the pkg to production, and it fails because of the following:

[ISS.0098.9014] BrokerException: Client Contention (201-1034): Cannot reconnect client ‘mybroker.Trigger_onResponse’. Cannot change shared document ordering property while reconnecting to an existing client.

i assume it didn’t like that i changed the mode from serial to concurrent midflight. what’s a recommended solution on how to get around the problem?

Hi Fantony,

You are facing this problem because broker client queues are still referring to old trigger properties. You will have to reset the broker client for the trigger that you are changing.

Following steps should solve your problem.

  1. Disable triggers on all the cluster servers. (If clustered.)
  2. Delete the broker client.
  3. Enable the triggers.


1 Like

yes! that solution worked. thanks!


We are facing the same issue on IS711…Do we have to follow the same procedure?

How to delete the Brocker Client?? via MWS or IS/Settings/Messaging??

Doc Queues are piling up… and Connected is NO

Pls advice…



I am not sure about IS 7.1.1 but from IS 6.5 you can delete broker client from BrokerAdmin (hostname:7788 > Brokers > [COLOR=blue]QABroker@hostname:7788[/COLOR] > Clients > Delete (

or from MWS(Messaging–>Broker—>Broker Client queues, their would be a checkbox beside the queue. Select the checkbox of the client that you want to delete and click Delete button).

It would be more or less same with IS 7.1.1


traced it…ty