Send External Request Document Failed


I’m getting the following error in the ‘Send External Request Document’ step.

Error trapped in service:
Error: Error: Error while executing service wm.ip.trp.trputils:encodeNSend [ESIPRT.000000.000001] Error Message: Transport not found for {0} [ESIPRT.000020.000005] Suggested Action: Level: Level: Service Call Stack: com.wm.ip.trp.InvalidTransportException: Transport not found for {0} [ESIPRT.000020.000005] at wm.ip.trp.trputils.getTransport( at wm.ip.trp.trputils.encodeNSend( at java.lang.reflect.Method.invoke

While debugging i found, after Outbound map step the RN object is not there…
while executing service wm.ip.trp.trputils:encodeNSend,in the bizEnv/ContentParts the ServiceHeader,ServiceContent,rndata,content data are not there…

any suggestions?

Help!!! Help!!! Help!!!


Hi Arun,

What version of RosettaNet are you using? Also do you have your WmRNIF11TRP and WmRNIF20TRP packages loaded?


Hey Raghu,

can you have a look on my recent post, topic is Pip3A4_Buyer_Model_new.Design_Server:Send_PO_Request - error in getInstanceID

and give me some suggestions…



I’m getting the same error as yours in the ‘Send External Request Document’ step.
If you solved this problem, please,can you share the way to apply into webMethods ?

We are using the IntegrationServer6.1 and RosettaNet6.0.1+SP1.


Hello Guys,

 We have also installed RN6.01 SP1 recently, and from there on we are NOT able to identify the RNO's in TN, have you guys seen this before??.

 every thing is being identifed as unkown .., on the other hand the RNO data is also not seen in TN console document view?

 Please help.