SAP R/3 Adapter 4.6 library error under webMethods 6.1

Hello,
I upgraded from Integration platform 6.0.1 to the new 6.1 version under AIX and got an error from the SAP adpater startup service about missing RFC-libraries. The libraries (sbc46SR5libsaix) worked well in version 6.0.1. I tried some other versions of the libraries, but none solved my problem.
Does anyone have some ideas ?

Thanx,
Uli

Error message:“JCO.classInitialize(): Could not load middleware layer ‘com.sap.mw.jco.rfc.MiddlewareRFC’ Can’t find library sapjcorfc (libsapjcorfc.a or .so) in java.library.path”

I’ve changed the java-version from the AIX 1.4.1 64-bit to the AIX 1.4.1 32-bit version -> the SAP Adapter starts up successfully.

can u pls tell us how did u start JVM in 32-bit mode. We are working with webmethods 6.1 on Solaris platform with JVM 1.4.1. Your help will be much apreciated.

By default the jvm starts in 32bit mode. It is only running in 64 bit if you use the -d64 java option.

Liam

thanks liam,

yes we were eventually able to figure out how to start JVM in 64-bit or 32-bit mode. But this still doesnt resolve our issue.

WE have tried these options so far

  1. installed SP4 and SP5 for SAP adapter
  2. started JVM in 32-bit (explicitly by putting -d32) and 64-bit modes
  3. included JAVAHOME in root profile

Pls note that we are working on Sun Solaris platform with 1.4.2 JRE and Webmethods 6.1

If you think there are any other options that we can try then will be very helpful.

Regards
Gaurav

Hi Gaurav,

I’ve got the same problem. If you find a solution, please inform me.

mailto:robert.stockinger@wienit.at

regards
Robert

Please check your location where you installed the library for SAP.

wM is checking some places to add these libraries automatically to the library path during startup of the server.

Maybe this lookup function has changed from 6.0.1 to 6.1!

See server.sh for details.

Common directories are:
<IS_ROOT>/lib
<IS_ROOT>/lib/jars
<IS_ROOT>/lib/system
<IS_ROOT>/packages/SAP/lib
<IS_ROOT>/packages/SAP/code/jars

Regards,
Holger

Hi all,

it seems, that SAP does not support a 64 Bit java jco library. So the only way is to step back to jvm 1.3.
If the focus of stepping to jvm 1.4 was the memory, there is a different solution for the aix.

just add the following line to your server.sh before starting the IS.

export LDR_CNTRL=MAXDATA=0x20000000

The hex code depends on the needed memory.
IBM describes that on the following url:
http://www-106.ibm.com/developerworks/eserver/articles/aix4java1.html

regards
Robert

Do check the code/libs folder for the jars libsapjcorfc.so and librfccm.so. This resolved the issue in my case