SAP adaptor connection pool keeps growing

I am running SAP Adaptor 4.5 (SP5 build 625) hosted on IS 6.1 on Solaris platform. Overtime, the SAP adaptor connection pool size out-grows its maximum size (set to 100) causing subsequent requests to SAP to wait indefinitely. Eventually I have to restart the IS hosting SAP Adaptor. I also noticed that “locked session” count reamins to ZERO when pool size keeps growing (ruling out the possibility that services are locking SAP sessions but not unlocking them). I set SAP Adaptor params as follows:
Timeout (minutes) 3
Timeout check period (seconds) 5
Sessionpool size 100
Poolqueue waiting time (seconds) 30

At any time, the transaction volume for SAP does not require more than 10 sessions simultaneously. I wonder if it would be an internal problem with connection polling in SAP Adaptor.

If anyone eccountered this problem and more importantly fixed/worked around it, Pls. share.


I am also having a similer problem. We have configured the pool size to 10.
When our sap system is down, Business connector tries to connect sap system as the sap system is down it can’t , mean time the pool size value is reached to 10(Maximum) .

When the sap system is up the Business connector will be connected to sap system only after resetting the pool size to 10 manually.

But we need a solution to reset the pool size automatiocally when it reached maximum?

Hi Shoibm,
if this is really a bug, you should open a wM ServiceRequest. But I have never seen something like this, so there is still a chance that the connection is indeed locked somewhere and not returned to the pool. (I think there has been a bug in the locked session counter once… So if it shows zero, that doesn’t proof much…) In any case you should get the latest update (SP 8?), if only to get the locked sessions counter fixed.

Regards, Lanzelot

we did have this problem, when SAP was restarted without the connection being disabled.

during the restart, if any documents are sent from SAP BC or wM, the connection pool increases to a maximum and then this problem occured.

However, the Connection/listener is temporarily disabled in wM during the restart and the problem is solved.