Sap adapters -

hello everyone
Im try to install and activate SAP adapters with fix SAP_7.1_Fix6[TABLE=“class: tableView”]
[TR]
[TD=“class: evenrow”]Package Name[/TD]
[TD=“class: evenrowdata-l”]WmSAP[/TD]
[/TR]
[TR]
[TD=“class: oddrow”]Version[/TD]
[TD=“class: oddrowdata-l”]7.1.0.0.718[/TD]
[/TR]
[/TABLE]
on Webmethods IS 8.2- windows server 2003 R2
I download from sap last version of JCO 3.0.8

[TABLE=“class: tableView, width: 100%”]
[TR]
[TD=“class: heading, colspan: 2”]Load Errors[/TD]
[/TR]
[TR]
[TD=“class: oddcol-l”]Name[/TD]
[TD=“class: oddcol-l”]Reason[/TD]
[/TR]
[TR]
[TD=“class: evenrowdata-l”]wm.sap.Admin:registerAdapter[/TD]
[TD=“class: evenrowdata-l”]Incomplete JCo installation: sapjco3.jar or native sapjco3 libraries are missing. When installation is complete, ensure that JVM option “-XX:-StackTraceInThrowable” is not set![/TD]
[/TR]
[TR]
[TD=“class: oddrowdata-l”]wm.sap.Admin:registerLocalConnection[/TD]
[TD=“class: oddrowdata-l”]WmSAP Adapter: Error on creating new Object: [ART.118.5042] Adapter Runtime (Connection): Unable to enable connection resource wm.sap.internal.cs:emptyConnection. [ART.118.5022] Adapter Runtime (Connection): Cannot create connection wm.sap.internal.cs:emptyConnection. Adapter type WmSAP does not exist.[/TD]
[/TR]
[TR]
[TD=“class: evenrowdata-l”]wm.sap.Admin:registerRoutingListener[/TD]
[TD=“class: evenrowdata-l”]WmSAP Adapter: Error on creating new Object: [ART.114.3] Adapter Runtime: Unable to get information about adapter type WmSAP.[/TD]
[/TR]
[/TABLE]

I got those erros after followed instructions from documentation ; I already checked on empower Knowledge Center and nothing for helping.
somebody knows what to do?

Thks for help

Is your SAP adapter installed & registered fine? Can you run pub.art:listRegisteredAdapters service and check if it is listing SAP Adapter.

-Senthil

Pls refer to SAP note 0000684106 as stipulated in the SAP Adapter Installation and User’s Guide.

Get the Microsoft Visual C++ 2005 Service Pack 1 Redistributable Package (KB973544) here at:
http://www.microsoft.com/technet/security/bulletin/MS09-035.mspx

Download one of the following platform-specific files:

  • Itanium System: vcredist_IA64.exe
  • 64-bit SAP system on Intel 64-bit: vcredist_x64.exe
  • 32-bit SAP system on Intel 64-bit: vcredist_x86.exe
  • SAP system on Intel 32-bit: vcredist_x86.exe

Hi Senthil,

I have ran the pub.art:listRegisteredAdapters service but I did not find SAP adapters in that list.

How to register a SAP Adapters on wM Integration server.Please guide me

Thanks & Regards,
Jeevan

[FONT=times new roman][SIZE=3]

If you are running Integration Server as a service, run register dll command to start the SAP Adapter[/size][/font][SIZE=3][FONT=trebuchet ms]

[/font][/size]

Refer SAP Adapter Install and Users guide - page 52 for more details