SAP Adapter 4.6 partially loaded on IS6.5

Hi Guys,
Ive got a SAP 4.6 Adapter running on a IS6.5 (HP-UX)

I see the following 4 error lines in the SAP package under package management.

I see the following load errors in the package under package management.

sap.admin.bor:getKeyfieldProperties
[ISS.0026.9106] No method getKeyfieldProperties in class sap.admin.bor

sap.admin.listener:getFunctionInterface
[ISS.0026.9106] No method getFunctionInterface in class sap.admin.listener

sap.transport:inspectPipeline
[ISS.0026.9106] No method inspectPipeline in class sap.transport

sap.admin.bor:getBAPIInterface
[ISS.0026.9106] No method getBAPIInterface in class sap.admin.bor

I have tried installing the wMPartners package & the SAP package.
I have manually tried to unzip the wMPartners.zip & SAP package and reloaded them.

But invain !!

I have the following info about the SAP Adapter if that helps you guys help me
:slight_smile:
Product webMethods B2B SAP Adapter
Version SAP Adapter 4.6 SR1 Release Notes
Build Number 610

Environment
JayCo Version 2.1.8 (2006-12-11)
JayCo Middleware sapjcorfc
JayCo Middleware Version 2.1.8 (2006-12-11)
jRFC Library Version 2.1.8 (2006-12-11)
jRFC Library Location /webMethods6/IntegrationServer/packages/SAP/code/libs/libsapjcorfc.sl
RFC Library Version This RFC library belongs to the SAP R/3 Release *** 640,0,165 *** MT-SL Versions of SAP internal libraries: dptr: 2 ni : 37 cpic: 3 rfc : 3
OS Version B.11.11
Current User AdminUser
Working Directory webMethods6/IntegrationServer

I still see SAP Adapter complaining about the same 4 things.
What did i miss out on?
All help would be monumentally appreciated
Scoobydoo !

I would suspect a mismatch of the SAP libraries with the adapter. You might double-check what versions of the JayCo/jRFC are required by the 4.6 SR1 adapter. Just a shot in the dark.

Rob,
It did complain earlier about the version mismatch.
So i fed it the newest version and it shut up.
Im thinking its something else other than the version.

:frowning:

It may be a minor version issue as it is complaining about specific methods within SAP-provided classes. Or perhaps there may be multiple SAP libraries on the classpath and there is a collision?

Rob,
I looked and looked .
I’ve checked and double checked.
Ill post the remedy once i get a response from the tech support for those who come in search for an answer
:wink:

-Scooby !

Rob,
I guess i had a bad SAP.Zip package.
I downloaded a brand spanking new package from advantage.
Removed the old SAP and replaced with the new one.
Works like a charm.

Thanks for all the help rob.
Scoobydoo!

Hi Scoobydoo,

I need a small information from u.How u downloaded wMPartners.zip .

Can u provide exact link for that.I treid several times but i didn,t get that so can u provide that.

I’m trying to install on windows2003.IS version is 6.5 only.

Thanks,
-Reddy.

Reddy,
Check the following thread. Partner manager package should be in the same location.

http://wmusers.com/forum/showthread.php?t=13400

gvbreddy,

wmpartners package is an option that you can exercise while installing your IS.
Select this during installation or image creation.
Use the webMethods Install Wizard to download this package seperately if you have already installed Integration Server.
So scroll through the option tree.
Hope this helps.
Scoobydoo.

scoobydoo,

Thanks for ur help.

I got it WmPatner.zip.

It’s working fine.

Thanks,
Red