Running Anounymous WS


I’m trying to run a service anonymously, w/o providing granting.

What I did is :

  • Called service : Execute ACL = Anonymous (inherited), others DEFAULT
  • WSD : Execute ACL = Anonymous (inherited), others DEFAULT
  • Parent directory : Execute ACL = Anonymous (inherited), others DEFAULT
  • Top directory : Execute ACL = Anonymous, others DEFAULT

Unfortunately, when I’m trying to call my WS from a PHP code, I got :

Warning: SoapClient::SoapClient( failed to open stream: HTTP request failed! HTTP/1.0 401 Invalid Session ID or Session Expired

If I try this URL on my browser, I’m requested for my credential :confused:

Where I’m wrong, what I missed ?



Laurent, What happens when you try run a test from SoapUI or Quasar for your webservice? Do you still get an error?

Just leave the WSD as Anonymous and leave the rest of the layers as is.


You may need to set the READ ACL to anonymous as well, but I’m not sure.

By default IS sets Read ACL as “Anonymous” and this is the (inherited) acl for WSD.

Setting executable ACL in WSD is enough for accessing the services those are contained by WSD.


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.