Retrieving data via SAP custom Function Module and SAP Adapter

Hi all,

I need to retrieve data from SAP table, using a custom Function Module. The function has a table as one of it’s input parameter, serves as a filtering criteria.
My question is, the function retrieved data correctly in SAP GUI. However, when trying to do the same thing in WebMethods SAP Adapter web UI (SAP Adapter --> Lookup --> Function By Name --> Test Function), the data returned is ignoring the table input parameter. I’m passing the exact same parameter for both execution, in SAP GUI and SAP Adapter Test Function.

webMethods Integration Server v 9.6.0.0
webMethods SAP Adapter v 7.1.0.12.864, SAP_7.1_Fix12

Could you please help.
Thanks in advance.

Try to create RFC adapter service thru and selection the function to test and make sure BASIS/owner has already given the RFC acess to the webmethods user.

HTH,
RMG

Hi Mahzan,

can you share the About-Page of the WmSAP-WebUI?

Is the structure showing up in the DDIC-Cache after looking up the RFC-function?

Latest available Fix for SAP-Adapter is Fix14 which enables the JCo-Version 3.0.13 to be used.

When using an older JCo-Version it will only work up to SAP_7.1_Fix13.

When receiving data from SAP within wM you should opt for an RFC-Listener which registers itself with SAP server.
When sending data to SAP do how RMG has suggested.

Regards,
Holger

Hi Mahzan,

Check the function module in SAP

  • If properly activated CTRL+F3
  • Check CTRL+F2

Create Adapter service in the designer. Then create a flow service with the adapter service. After this initialize the table in the flow. Just a “set value” and save. Then test.

  • Also try to clear the DIDC cache

Regards - Rob

Yes all the above suggestions could help you to resolve this issue and work along with your SAP team as well. :smiley:

HTH,
RMG

Hi all,

Sorry for the late reply. Thanks for all the suggestions. I’ve talk to our SAP team, it seems that they’ve fixed it in the function module code. Inside the function it’s calling another BAPI, and the results from that BAPI needs to be assigned to the local table variable.

Now it works, with SAP GUI, SAP Adapter test function, flow services, etc.
Thanks.

Very Glad to hear issue resolved and thanks for the updating back! :smiley:

HTH,
RMG