Reset Portlet State for Navigation Issue

Hi Guys,

i have to following situation:
I have a shell, which has a portlet with navigation links at the “left navigation” part.

When the user clicks on a navigation link, it navigates to another public folder with the requestet content(another portlet). The shell, and the navigation portlet still remain on the site, so only the “content portlet” changes.

I hava a “content portlet” which first shows a overview over some business objects, and when you click on one, it switches to a details view, where you can inspect some assets of the business object.
My problem is now: when the user clicks in the “navigation portlet” to request the same “content portlet” again, it still shows the details view, but it should show the default-overview-view.

I already tried quite some options to create the expected behaviour, nothing succeded.

My most promising try was this one: portlet simple link like here:http://193.26.193.139/viewtopic.php?p=68268&sid=821d236527fafac838a3501f8f73e0d8#68268
But it wouldn’t work.
Then i tried to change the “navigation portlet” link, to add the “?sh.wmp_rs=true” parameter, but it has a strange effect:
It resets the portlet state just how i wanted.
But when i interact with the fresh resetted portlet, e.g. i click a commandlink on that view(to get to the details view), it does not navigate.
Instead it just reloads the default view(to remove the “?sh.wmp_rs=true” parameter from the url) and i have to click the business entity again so the portlet shows the details view, which is unacceptable.

Any help, how to solve my navigation issue is appreciated and thanks in advance for your time!

I think i found the solution myself.

You shouldn’t use the URL parameter “sh.wmp_rs=true” because it will reset all portlets on your page. You should instead use your Portlet identifier like “wmp14612.wmp_rs=true” to reset only the content portlet. I did this by hand, but i’m sure you can configure Portlet Simple link and Extended Portlet URL for this to work.

Hi,
Extended Portlet URL also has this property. In the expert properties of the Extended Portlet URL you’ll have 2 properties KeepState and Reset State which can take either true or false.
You can set this value here and try it.

Thanks,
Sravan