Publish to broker error

When i publish a document to broker im getting this error :
BrokerException: No Permission (109-1374): Cannot publish the document. Permission is denied. Check the ‘can publish’ permissions in the client’s client group. The properties are set to Publishable = True

any ideas how i can get over this error?


Assuming you are running webMethods 6.x…

And assuming you are publishing by calling: pub.publish:publish…

The Broker ‘can publish’ permission is created for the Integration Server’s client group (The client group is named “IntegrationServer”)automatically when you make an IS document publishable.

This doesn’t prevent the permission from being removed later. Also, the old legacy Broker tools allow you to create document types and set permissions in a variety of ways not compatible with the default Integration Server settings.

In Developer, make a note of the Broker doc type property.

Go to the Broker Administrator, and navigate to the Integraton Server Client Group. Click on the Can Publish Types link (it will be a number) and carefully scan the list for the Broker doc type you noted above. Considering the error message you got, you should not find it. You can add it by clicking the Add Can Publish Document Type link at the top of the page. On the next page, put a check mark next to the missing document type (again the Broker doc type you noted in Developer above) and click the Add button at the bottom of the page.

Hey Mark thanks for the response, that really help i was missing the doc type in my IS client group, so i added like you said. Works fine now.

Thanks again

I think in the Developer, you could have gone to the document, right clicked and and selected Sync with Broker, then selected Push To Broker
for the same results.
If you tried this and the document was not in the list on the Client Group, your Developer might have a problem (maybe the file permissions need to be fixed on the Broker’s machine).