pub.client.ldap:search --- multiple strings of same attribute instead of string list

I am attempting to use the pub.client.ldap:search service and all is working except in my results, if there is an ldap attribute where that object has more than one value, I see multiple strings with the same name instead of one stringList with multiple values. For example, my company’s ldap has an attribute “groupMembership” and my Person object has 6 groupMemberships. When I look myself up, I end up with 6 “groupMembership” strings in my result document instead of 1 “groupMembership” stringList with 6 entries.

We are upgrading from 7.1.3 to 9.6 and we previously used the ldap search that is now deprecated. We did not have this issue with the deprecated pub.ldap:search service.

Hi Troy,
This not an issue. this is how it works now. You are getting result. Now you have to manipulate in the way you want to see.


I have been trying to use service: I am passing the following inputs:


I am not getting any results out of document in the output.
How can we pass a numm array in returnattribute ? So that all attributes come in the output?


What is the accepted way of dealing with this non-standard and non-backward-compatible change? I tried setting ‘isDocumentList’ to ‘yes’, but it still returns multiple strings of the same name instead of a StringList? How do you pull these into a structure that can be looped over?

Asper my knowledge it can only be deal with writing custom java code to to fire LDAP query and form result as per requirements…