process not getting triggered.

Hi All,

Need your help to resolve the following issue.

I have created new business process, generated from Designer and also enabled the model from MWS.
Version: 7.1.1

This model is subscribing the document in receive step (first step).

Once i publish the document to broker, this model is not getting triggered. I could see error message in IS–>Server Logs–> “Trigger Resource Monitor invoked “wm.prt.admin:monitorPRTDB”. Status of resource is “not available”.”

If I run this service from IS Administrator(monitorPRTDB), it showing "isAvailable=False"

  1. When i check the subscription trigger from MWS for this model, I could see the document which i published (total 2 docs) on Queue.
  2. There is no model subscribing the same document.
  3. I have checked the connectivity for Process Engine & Process Audit Log from JDBC pools, that is fine.
  4. I checked the MWS–>Administrator->Business process-> It showing model is enabled and Used as “No”

Could you please advise, how to resolve the issue. Thanks!

I tried installing latest fix for process engine 7.1.1, but there is no luck

Any body faced this issue? I am getting the same error in IS server log.
“Trigger Resource Monitor invoked “wm.prt.admin:monitorPRTDB”. Status of resource is “not available”.”

I have tried recreating scripts for process engine, process Audit and that’s also not working. Getting the same error and my documents are getting stuck in process model subscription trigger and not initating the process instance !

WmPRT - v7.1.1 (Latest PRT fix for 7.1.1)

Could you please guide me, how to resolve this issue. Thanks a lot in advance.

Change Process Engine functional alias (JDBC Pools), and set min connection to 0, and restart IS.

was it solved??

It’s working fine now without any issues after the JDBC tool configuration which is mentioned above… Thanks a lot to everyone.