Process Models

Just a question about Process Models. I am using webMethods I have several models in MWS. Two are enabled for Execution and Analysis. I had been able to view the “lemmings” and process count until a recent SAN incident. Now I get the message “No Process’s Enabled for Analysis”. I can see the process’s are going through via the Process Instance tab. Error’s that show up are: Failed to evaluate binding expression: “#{processModelPageBean.overlayScript}” and

Failed to evaluate binding expression: “#{problemEventsPageBean.getProcessProblemsBean.result}”

Less importantly is another model that I can not enable for analysis and an used model I can not delete. I’ve searched the forums and have tried the methods listed. Your comments and suggestions are appreciated.

You cannot delete a used process model using MWS admin console. Need to implement archive and delete to clear the process instance, after which you need to manually delete the entry from DB ( wmprocessdefinition table).

You can find more information in webMethods Monitor User’s Guide Version 7.1, chapter 7

Ok, but the documentation says that you should be able to delete an unused model from the MWS GUI. I was able to get rid of this model by running the getUnusedModel flow getting the Model Key ID then running the deleteUnusedModel flow using the data above. I also ran the setModelEnabled flow. All this took effect when I did a restart of the MWS and IS.

I faced a similar problem, when i tried to delete an unused process model via MWS admin console,i ran into socket timeout exceptions. After restart of IS and MWS, i was able to delete the model using MWS admin console.

One other thing you can notice is, the delete button will be active for an unused model, letting you delete via MWS admin console, which is not the case for a used process model.

As i mentioned before, you have to follow the instructions mentioned in wM Monitor user guide, to get rid of used one.

Hi Stobias,

Did you check if your analytical engine is up and running, also in the procesistance page there is an option for choosing what type of proces intace u wnt view (e.g. BPM only,BPM and analysis). it will be in the right corner in the processinstace page.
Try suffling and check if you are geting the same error.


Oh yes I have checked the different views. I usually just stay on the BPM BAM view. Thanks for the info.