Problems with Idoc going from 3.52 to 4.7

I have a flow in our current 3.52 WM installation that is working fine. We bring in XML data and it converts it to an Idoc and loads it into SAP without any problems. however, when I installed 4.7 on our test system and ran the same flow, I get the following error:

com.wm.util.coder.InvalidDatatypeException: com.wm.lang.xml.WMDocumentException: Invalid IDocXML document: Only segments are allowed on top level, found non-segment E1EDK01

Can anyone give me an insight as to what this might be? We are trying to move everything into production this weekend and I need to have this solved before then. Any help would be GREATLY appreciated.


At what point/flow step you are getting the above error?Did you changed any IDOC doctype or version wrto new4.7??Is E1EDK01 segment part of your existing IDOC Schema/doctype?? Please elaborate if you have done any type of cosmetic changes in your flows during upgrade to Adapter/SAP newversion.



All I did was export the package from my 3.52 installation and load it into my 4.7 installation. When I run the flow, I paste in the xml data. Everything looks good in the results until it gets to the SAP:Decode step. That’s when I get the error I listed below. I haven’t changed anything in the flow at all, but I have had a couple people tell me I need to reload my idoc structure. Since I never did that in the past, I don’t know what they’re talking about. Any ideas??