Problems enabling cluster

We have enabled cluster as per the manual and we see the cluster comes up and then there is a message every 3 minutes which indicates that the server is removed from cluster.

In our configuration we have two machines and each run 3 instances of integration servers svr1,svr2 and svr3. The corresponding svrs in each machine are clustered.

2004-10-14 08:35:33 CEST [ISS.0033.0109D] Server svr1 added to cluster WEBM_CLUSTER_NAME
2004-10-14 08:35:33 CEST [ISS.0025.0016C] Config File Directory Saved
2004-10-14 08:35:33 CEST [ISS.0025.0025C] Broker Synchronizer initialized
2004-10-14 08:35:33 CEST [ISS.0014.0002C] Initialization completed in 391 second
s.
2004-10-14 08:50:03 CEST [ISS.0033.0110D] Server svr2 removed from cluster W
EBM_CLUSTER_NAME
2004-10-14 08:53:03 CEST [ISS.0033.0110D] Server svr2 removed from cluster W
EBM_CLUSTER_NAME
004-10-14 08:56:03 CEST [ISS.0033.0110D] Server svr2 removed from cluster W
EBM_CLUSTER_NAME
2004-10-14 08:59:03 CEST [ISS.0033.0110D] Server svr2 removed from cluster W
EBM_CLUSTER_NAME

Balajee,

Try setting the node names to the hostnames/ip-addresses of the machines instead of logical names and make sure the machine running the repository server is able to “ping” those names.

regards,
Jordy

Hi Jordy,
Thanks for the tip. I have done it. The repository server is running on one of the IS machines and has access to both. Still the problem exists.

Thanks,
Balajee

Rebooting the boxes might help.
http://advantage.webmethods.com/article/?id=SR-1-47528421

Can you elaborate? Implied in this statement is that there are two machines, each running 3 IS instances, both machines using the same set of names:

Machine 1
svr1
svr2
svr3

Machine 2
svr1
svr2
svr3

And there is one repo server being used by all instances on both machines? The machine 1 instances are in a cluster and the machine 2 instances are in a different cluster? What are the cluster names?

I had the same problem got this one resolved. I increased the log level and found out that the
second server is unable to register connections with the first.
There is a problem with the ACL created automatically with the
remote servers. I changed it to use ACL

And this issue doesn’t arise anymore.

Server Log Entries as of 2006-02-22 10:31:14 CST

After Change:

[3937]2006-02-22 10:30:37 CST [ISS.0079.0100V2] Registered 3 Reverse
Connections with alias:CLUSTERCAUSTDSW0783
[3936]2006-02-22 10:30:37 CST [ISS.0080.0101V2] SocketLink successfully
created to endpoint:CAUSTDSW0783:8898
[3935]2006-02-22 10:30:37 CST [ISS.0080.0101V2] SocketLink successfully
created to endpoint:CAUSTDSW0783:8898
[3934]2006-02-22 10:30:36 CST [ISS.0080.0101V2] SocketLink successfully
created to endpoint:CAUSTDSW0783:8898

Before Change:

[3933]2006-02-22 10:29:37 CST [ISS.0033.0110D] Server CAUSTDSW0783 removed
from cluster WEBM_CLUSTER_NAME
[3932]2006-02-22 10:28:07 CST [ISS.0079.0100V2] Registered 0 Reverse
Connections with alias:CLUSTERCAUSTDSW0783
[3931]2006-02-22 10:28:07 CST [ISS.0079.0101V2] Unable to register Reverse
Connection with alias:CLUSTERCAUSTDSW0783
[3930]2006-02-22 10:28:07 CST [ISS.0080.0101V2] SocketLink successfully
created to endpoint:CAUSTDSW0783:8898
[3929]2006-02-22 10:28:07 CST [ISS.0079.0101V2] Unable to register Reverse
Connection with alias:CLUSTERCAUSTDSW0783
[3928]2006-02-22 10:28:06 CST [ISS.0080.0101V2] SocketLink successfully
created to endpoint:CAUSTDSW0783:8898
[3927]2006-02-22 10:28:06 CST [ISS.0079.0101V2] Unable to register Reverse
Connection with alias:CLUSTERCAUSTDSW0783
[3926]2006-02-22 10:28:06 CST [ISS.0080.0101V2] SocketLink successfully
created to endpoint:CAUSTDSW0783:8898
[3925]2006-02-22 10:28:00 CST [ISS.0014.0016V4] Invoking service
wm.server.admin:setSettings

Thanks,
Ramesh.

Ramesh,

Where did you configure the ACL for the repo server?

Mark

Found it.

When you use Settings -> Repository to define Repository Server Aliases, IS automatically creates remote server aliases as well. However, it creates them using the Repository Server Alias as the “Host Name or IP Address”.

As of IS 6.5 SP2, the ACL settings for this remote server alias were correct. However, the hostname/IP address property had to be changed to an actual hostname or IP address rather than the repo server alias name.

Mark