Problem to publish a document on the broker

I’m a beginner in webmethods development and I try to publish a document on the broker, and then I configured a trigger to use this document in an other flow.
But when I use tracePipeline to see if the document is correctly published,
I get this message: — START tracePipeline [11/04/11 12:06] —
2011-04-11 12:06:46 CEST [ISP.0090.0008C] 0 node {com.wm.lang.xml.Document} = ‘DOCUMENT System ID: null Public ID: null’
2011-04-11 12:06:46 CEST [ISP.0090.0002C] — END tracePipeline —
And when I use tracePipeline in the other flow, It returns “null” so I concluded that the document isn’t published but I don’t understand why.
Can someone please help me ?

Looks like you are using native messaging and trigger. High level steps are:

  1. Create a document type.
  2. Make document type publishable.
  3. Sync (push) the document type to Broker.
  4. Write a simple service with pub:publish and use the created document type.

It will be easier to find a ready to use sample publishing package.

First, thank you for your answer.
The process you’ve described is exactly the same that the process I followed.
But it still not work.

Any errors on IS logs?

Check your IS is connected to Broker (not local publish), this can be checked on IS messaging settings.

Then make sure the namespace of the publishable document that is mapped to pub.publish:publish is same as the input to the subscriber service.

Also, verify the trigger whether you have selected the above document type and service. Check if triggers document processing and retrieval are enabled on IS trigger management page.

If all the above are correct, then we can check on Broker via MWS if it is published and subscribed correctly.

Do you have access to MWS?

Hi Mile,

I have attached a sample created based on the steps which you have mentioned this might help you

Manoj (15.3 KB)

Hi, thanks for your replies.
Sorry, I was in holidays so I couldn’t answer earlier.
M@he$h, I have access to WMS, how can I check if the document is published and subscribed correctly ?

And the message displayed in server.log is “null”.
Sorry for double post.

You can check number of published messages counter in page Broker > Statistics.
Or, you can check number of published messages in client statistics page. And, check number of enqueued/retrieved message on subscriber client trigger.

If you suspect that message is published successfully from IS, but got lost somewhere, then you can create a dead letter queue (Broker > Dead Letter Queue) to find if Broker is dropping the message because no subscriber exists.

Refer to Broker Administrator guide for more details.

Sandeep answered on my behalf, try it out.

The number of published messages is 0 so I conclude that the problem come from my BIS publish.
Here is a screenshot from that part.
Did I make a mistake?

Looks correct to me.
You can check the value of “local” once. If it is defaulted to true, then IS will do message routing within itself.

If that doesn’t help, then try the sample package uploaded by Manoj. That package should work, and then you can compare that with your package.

Hello Hugo,

Can you please check whether the Broker sever is connected succesfully with the IS.
If so trying pushing the published document to Broker server hope you have createad the Guranteed document.
Also from the attached screenshot what is the value you are trying to overrride since the pipeline should have the values already.