Portlet Include/Embed Issue

Hello experts!

I have two portlet applications: A and B. A is my main application.
B receives some parameters as portlet preferences. These parameters are input to an webservice called by an action bound to a async button.

In A, I have two views, 1.view and 2.view.

  • In 1.view, user inputs some data and navigate to 2.view,
  • In 2.view, there is a ‘Portlet Include’ control referencing B. Parameters are data inputted by the user in 1.view .

When I run A for the first time and navigate to 2.view B renders and works perfectly. But when I navigate back to 1.view and then again to 2.view, ‘B portlet’ is already loaded with previous data. Not the expected behavior, as B should be “empty” whenever 2.view is loaded.

I’ve read some posts/articles here and it seems that ‘Portlet Include’ just creates some reference to an existing portlet instance. I thought that this could be solved by changing ‘Portlet Include’ to ‘Portlet Embed’ as it creates a new instance of the portlet.

The problem is, when I use ‘Portlet Embed’, MWS just crashes with an error: "[POP.001.0002] A “javax.portlet.PortletException” occurred with the Message “java.lang.NullPointerException” ". What am I doing wrong?

Additionally: is there any way to reset previous portlet instance state using ‘Portlet Include’?

I am using webMethods 9.6.