[POP.012.0001.wm_cafshared/hidden] A server error occured. T

hi all,
i have diffent views in portlet and am importing the views in default view and in one of the view having table content provider and assycommangicon to add the table.

it is adding the data in table.

sometimes am getting below error

[POP.012.0001.wm_cafshared/hidden] A server error occured. The state of this page may be out of sync with the server.

regards,
anillendula

i am using webmethods 8.0 version and IE8.

what exact version of MWS/patch level do you have? I would ask support about it, since IE8 support is quite “new” and you maybe running an older 8.0.x version that does not support it…

best regards,
Javier

javier,

am using webmethods 8.0.1 version of webmethods and IE is 8.0, i have seen an announcement ON March 31 at communities http://communities.softwareag.com/ below is the announcement

May 31, 2010 - Announcement on General Availability of Service Packs in webMethods 8 suite
Software AG is also pleased to announce the General Availability of the following webMethods releases and service packs:

webMethods Broker & JMS 8.0 SP2
CentraSite 8.0 SP4
EntireX Adapter 8.0
ESB Designer 8.1
My webMethods Server and webMethods Task Engine 8.0 SP2
webMethods Process Engine 8.0 SP2
webMethods Monitor 8.0 SP3
webMethods Optimize 8.0 SP3
webMethods Designer for Process 8.0 SP2
webMethods Composite Application Framework 8.0 SP2

These updates can now be downloaded from Empower.

The highlights for the Service packs are:

Support for Internet Explorer 8
Support for Microsoft Windows 2008 Server R2
Updated Service Development Plug-ins

is this you are talking about this.

regards,
anil kumar ellendula

am using using webmethods webmethods 8.0.1 which i downloaded on 13/April/2010, the latest announcment on March pack is not updated in our environment, i mean is not available in our login credentials of advantages site to update our environment.

Hi Anil,
I suppose that is probably the problem… you need to see in the installer the SP2 version… check out with your sales rep or support. They will probably be able to help.

best regards,
Javier

Javier,

Thanks for reply, i check with the support team, they replied that it has been re-solved in wM8SP2, i have upgraded the my environment to wM8SP2 from wM8SP1, let me check this status in wM8SP2.

Regards,
Anil kumar ellendula

Hi, We are also facing the same issue in our environment for the past 3-4 months without any clue on the root cause. Lot of our custom developed CAF applications are throwing this out of sync errors quite frequently. Sometime the same error shows up on standard MwS pages as well.

We are on 7.1.3 and do we have any solution for this ?

Appreciate your help.

Hi Balachandar,
The reason for this error to come up is because of an Async call being performed to the server. If its possbile then you can chagne the Async Command icon to Command Icon. This will resolve this error.

Whenever there is a view navigation do not to use a Async Command Icon
instead use a Command Icon.

1 Like

Hi,

We solved this issue with a different work around.

I made an workaround that seems to solve the problem. Basically before the action (e.g. Search Action) we call an empty Async Hidden Command empty, this forces a sync between the browser and the server. This additional call for us it’s not a problem since this runs in a intranet, however in a internet this is an additional call :(. In any case this is only a workaround

BR

Hi,
We are currently using 7.1.3, and sometimes we get the same problem. This usually happens if a deployment is made to the application while the user is still logged in.

After a Logout and a clear cache in the browser the problem disappears.

br,
Vlad

Hi Herve,
We’re also having this problem now when executing a Search Action, but it only happens under high load, so it is difficult to reproduce.

Did you managed to reproduce the bug in controlled manner?

Did your solution had side effects?

br,
Vlad

Hi,

We are having the same issue and it happens only when there is a huge data involved.

We have an Async Table that has around 1000 rows and it is rendered via a webservice call after some time (obviously because of the huge data set).

When we sort on any of the columns, we get the message

[POP.012.0001.wm_cafshared/hidden] A server error occured. The state of this page may be out of sync with the server.

I beefed up the log level for several functions including wm_cafshared to Trace, but could not find any messages in the logs when this error occurs.

This is a Production environment and there is no deployment being done while a user session has been viewing a page from the deployment project, so this eliminates the other reason when we normally get this message.

We are on MWS Version 8.0.1.0.114

Anil, any luck with MWS8 -SP2?

Thanks,
Best regards,
Raj

Hi Raj,

Do you by chance have a loadbalancer in front of the MWS servers?

It is possible that this is the cause of bad communication?

br,
Vlad

Hi Vlad,

Yes, indeed we have a Load Balancer (BIG IP) fronting our cluster of 4 MWS. Have you had this problem because of a Load Balancer and if so, can you please advise on how you got it resolved if at all.

Thanks,
Best regards,
Raj

Hi Raj,

  Our SAG Support Incident on this issue is still opened. We do not yet have a solution.

  I will let you know if we manage to solve the problem.

  I'm sorry to hear that it also reproduces on version 8 (we plan to migrate soon).

br,
Vlad

hi All,

i am getting same error in portlet include control.

i have async table contains two-three columns and 100 rows data is populating i have used Data Prev/Next control in one portlet project.

in another project in portlet view i have used portlet include control to include above portlet which contains Async table.
i have punbished the project.

i have open the project in the browse, i can see the table rows data but i soon as i click next am getting [POP.012.0001.wm_cafshared/hidden] A server error occured.

can any one suggest me how to re-solve this.this proble, is happening in mozilla browser and Internet explorer as well.

Regards,
anil kumar ellendula

Any time that i hear about using a Portlet Include control, i wonder if you have nested Forms? That would cause this problem.

Hi mimel,

No am not using nested forms, just included other portlet in main portlet, main portlet and include portlet as same form Id name i.e deafultForm.
Can you please elaborate what you mean by nested forms in this error while doing portlet include.

Regards,
Anil Kumar ellendula

A nested form is a very easy situation to generate when you have one portlet include another portlet.

As you know, when you create a CAF Portlet, it generates a default .view file. That .view file always contains a CommandForm Control (with a defaultID). Unless you remove the child portlet’s Form, or take care to ensure that the Portlet Include control in the parent is outside of a form, you will wind up with nested Form Controls.

At runtime, when the forms render, it will generate html code like this (simplified of course):


<form>
  <form>
</form>

HTML doesn’t allow nested form elements.

From your description, i think that is causing this problem.

Regards,
–mark