Peoplesoft webservice works with SoapUI, gets http 500 when I run REQUEST DOCUMENT

Hello I am trying to write a REQUEST DOCUMENT statement to access a Peoplesoft web service. I get an HTTP 500 response when I run it, yet the same SOAP request works in SoapUI. What could be causing this? a difference in the headers? The SOAP request is the same unless I made a typo.

REQUEST DOCUMENT FROM #FROM                             
    HEADER 'Content-Type'  'text/xml;charset=UTF-8'     
**  HEADER 'Content-Type'  'text/xml;charset=iso-8859-1'
    'SOAPAction' 'UTZ_FP134_VENDOR_ADDR.v1'             
**  'Accept-Encoding' 'gzip,deflate'                    
**  'Content-type' 'text/xml;charset=UTF-8'             
    'Host' ''   
**  'Content-Length' '1548'                             
**  'Connection'  'Keep-Alive'                          
    'Request-method' 'POST'                             
**  'User-Agent' 'Apache-HttpClient/4.11(java 1.5)'     
    DATA ALL    #DOCUMENT                               
**    ENCODED CODEPAGE 'UTF-8'                          
      ENCODED CODEPAGE 'iso-8859-1'     
    HEADER ALL             #HEADER          
      NAME 'Content-Type'    #DOC-CHARSET   
    PAGE #PAGE ENCODED                      
RESPONSE #RC                                
  GIVING #RTERR                             

I have successfully written a similar request to a different PeopleSoft interface in Natural, yet this one perplexes me so far. Thanks for any help! (Notice I have a lot of stuff commented out that I have tried. I tried making the header like the SoapUI header).

whoops, forgot to post output.
GOODBYE #N3: 500
#HEADER: HTTP/1.1 500 Internal Server Error?Connection: close?Date: Thu, 01 Aug
2013 16:32:14 GMT?Content-Length: 524?Content-Type: text/xml; charset=UTF-8?X-
Powered-By: Servlet/2.5 JSP/2.1??


<?xml version="1.0" ?>">SOAP-ENV:BodySOAP-ENV:FaultSOAP-ENV:
ServerServer ErrorIntegration Broker Response<
Integration Gateway failed while processing the message</

:slight_smile: Solved my own problem. I found two very minor errors in the SOAP request, although I tried to cut and paste it from SoapUI. I left out some spaces which I found when I changed the mustUnderstand in the header from 1 to 0. Then I got some meaningful error messages.

   '<?xml version="1.0" encoding="UTF-8"?>' -                            
   '<soapenv:Envelope xmlns:soapenc=' -                                  
   '"" ' -                      
   'xmlns:soapenv="" ' -        
   'xmlns:wsa="" ' -    
   'xmlns:xsd="" ' -                    
   'xmlns:xsi="">' -       

I had left out the space at the end of some of the lines, and the SOAP envelope got confused.