one Integration server is not connecting to clustered broker

Hi,

We have a burning problem.

We are running two Integration servers installed on different linux servers.

We have implimented the Broker in a cluster.

Now the suddently one of our Integration server is not connecting broker, 2nd server is able to connect.

Eventhough we move the Broker to 1st server, 1st Integration server is not showing as Broker not connected, 2nd IS has connected = Yes.

server.log of 1st Integration server showing below information while starting the IS

“Broker Synchronizer has been disabled”

Thanks,
Prakash.

Hi Prakash,

Can you check whether dispatch.cnf in IntegrationServer/config directory had been corrupted. If yes delete it and also backup. Restart the server and reconfigure the broker. It should work.(Before deletion just take a backup of it in your local PC).

My$.2
Niteesh

Hi Niteesh,

Thanks for your response…

I have removed the dispatch.cnf and started the IS server.

Still the showing the same error

“Broker Synchronizer has been disabled”

We also found following error

including "[BAT.0002.0000] Wrapped Exception: com.webmethods.lwq.LwqException: Could not obtain a DB connection

So, support suggested the following solution

removed everything below IntegrationServer\db or even the db subfolder itself, and let them recreate by a IS start

problem solved…

Support suspected that… Corruptions of the embedded derby DB