Not able to retrieve time stamp using select service

Hi,
When I am trying to retrieve the time stamp from the DB by using Select adapter service, it is retrieving only the date but not the time stamp. But in the DB it is having the time stamp. I have installed the jdbc_fix_10, reload the service then also it is showing only date but not the time stamp.

can anyone pls provide the input.

Thanks,
Hari.

Hari,

What database vendor? What SQL statement are you attempting to use?

Mark

Hari,

If your query selecting Date/Time field from DB,then AS should retrieve the Date/Timestamp value as it is.I can confirm for Oracle/SQL.

What is you JDBC output field type is it java.lang.string?Also What happens if you tried the same query in TOAD or any SQL client

HTH
RMG

Hi,
I am using oracle DB, and I tried with for output field with java.util.date, java.sql.date and also java.lang.string. But I am getting only the date. When I tried in toad it is giving value with timestamp

Thanks,
Hari

Hi,

I’m facing exactly the same problem and I found on adavantage following:

JDBC Adapter not returning both Date and Time during SELECT. [Closed Service Request Summary]

[B]Article ID:  [/b]SR-1-60287291  [URL="https://advantage.webmethods.com/advantage?targChanId=kb_home&oid=1612578225#"]What is this?[/URL]

Quick Access URL: http://advantage.webmethods.com/article/?id=SR-1-60287291
Last Updated: 11-Oct-2005
Customer Description

We are using the JDBC Adapter to connect to an Oracle Database (9.2) where we are selecting a DATE field that includes both Date and Time information. The time information is always returned as 0.00.00 (eg. 10/3/2005 0:00:00 EDT). We tried implementing the setting described in SR-1-58258341 but this did not resolve the problem.
webMethods Closure Summary

  1. Install Jbdc Adapter 6.0.3 FP1
  2. Fix4 resolves the issue. Fix7 supersedes Fix4. Apply either one.
  3. Change the OtherProperties: driverType=<thin/oci>;connectionProperties={oracle.jdbc.V8Compatible=true}
  4. Get the latest driver from oracle website (necessary).
    Restart IS.

I hope it will solve this problem.

jogo

hi Jogo,
thanks for ur help. i am unable to find the JDBC_fix_4 or JDBC_Fix_7 can u pls give path from where we can download them.

Thanks,
Hari

Hari,

An Authorized Technical Contacts (ATC) for your company with software download privileges can usually download fixes from Advantage.

If your are one of those and can’t download the fixes, you should submit a Service Request asking for those fixes to be added to your download area. Support will also place fixes onto an FTP site or email them if they are small.

HTH,

Mark

hari, I have already fix the problem, I wrote some info here: http://wmusers.com/forum/showthread.php?t=9140

oracle.jdbc.V8Compatible=true is a java runtime setting, so you should be able to set this in the server.sh for the jvm to load this. Has anybody tried this with a new ojdbc14.jar?

equivalent would be:
-Doracle.jdbc.V8Compatible=true

This way you wouldn’t have to include it in every connection’s configuration that you require the behavior.