Not able to connect to oracle

Hi,

I am not able get the adapter connect to Oracle Database. Being a in the inital setps of webmethods, can u let me know the steps to be followed to set my adapter connect to oracle.
Oracle 8.1 is installed in the same system where the webMethods software is installed.

Thanks in Advance

Regards
Krishna

Hi,

You can following the steps below to check whether you have left anything out in your procedure:

(note: this is the procedure for windows OS)

  • place the Oracle Driver in a folder (e.g. c:\temp).
  • enter the classpath of the oracle driver into server.bat
  • start the server
  • log on to the Administrator Console
  • open up the database adapter
  • fill in the connection parameters

e.g.
Alias: transactions
DB URL: jdbc:oracle:thin:@localhost:1521:theDB
DB Username: user
DB Password: password
DB Driver: oracle.jdbc.driver.OracleDriver

After you have done this, try to connect to the database via the database adapter. Ensure that the username/password is valid.

Regards
Alex

Hi

if you are using JDBC driver, put the two jars files(classes111.jar,nls_charset11.jar) in /libs/jars ,IS automatically maps these folders at startup.

if you are using ODBC ,DB URL is jdbc:odbc:
hope this solves the connection problem.

regards,
prabhu.

Krishna, Can you tell us what webMethods product you are using? The answer to your question depends on whether you are using Enterprise Server or Integration Server. The answers from Alex and Prabhu will work if you are using Integration Server.

Also, can you post the specific error you are encountering?

Alex (or anyone),

I tried to use the Oracle driver directly instead of using ODBC but I experienced an error: “Could not connect: No suitable Driver”.

I added the classes12.zip file into Int. Server’s classpath and I verified in the runserver.bat file that IS is called with my zip file in the class path. But I still get the error.

Any thoughts?

Calvin - here’s what I would do to narrow the cause of your trouble down:

  1. From the Administrator (browser), go to Extended settings and edit to add this line (if it’s not already there):
    watt.server.jdbc.driverList=oracle.jdbc.driver.OracleDriver

This will pre-load your DB driver at server startup. Then halt the server and start it from the command line using -debug 5.
You will see a message toward the end of the startup procedure that will tell you if the server was able to load the driver or not. If not, it’s a classpath issue. If you place the classes in the server’s lib or lib/jars directory you’ll never have a classpath issue. If the server loads the driver successfully, go to #2.

  1. Double check the DB url. For Oracle’s thin driver the url should look like:
    jdbc:oracle:thin:@:1521:

Make sure you have a colon after “thin”.

Good luck!

Hi Calvin,

I got the same issues…

Following are the things i did …

  1. I forgot missed the “:” after the “thin” in the DB url…and corrected it.
  2. Created a classes directory under

\webMethods\IntegrationServer4\lib directory and unzipped the classes12.zip file…

It works fine.

cheers,
Rajesh

Calvin,
I would also check the version of the Oracle driver that you are using against the version of the Oracle database. In other words, I have had the same error while trying to use an Oracle 8.1.6 driver with an 8.1.7 database, and vice versa.

Tony

Hi Alex,

I also had the same issue. Two place We need to look.

  1. The DB URL must like this format “jdbc:oracle:thin:@hostname:port:SID”.

  2. You must place your classes12.zip in your integrationserver /lib folder and restart the server.

=Jeya=

Hi Tony (or anyone):

I am still having the DB connection issue. I verified that the DB URL is correct. I added classes12.zip into the class path (under IS, lib/jars file). I added the driver to the Extended Setting and IS did load the driver. However when I tried to connect to the db I still got a “Can not load driver” problem.

I’m trying to use the Oracle thin driver (not odbc).

I did notice that the version of the Oracle instance were different than the one I loaded on my machine. I’m running 8.1.7. And the Oracle instances that I’m trying to connect to are 8.1.6 and 8.0.5. Is there a way for IS to connect to other versions of oracle? Is there a way to have multiple versions of the driver on the machine?

If anyone knows the answer, please let me know.

Tony et al. ,
I figured out the problem. I needed to not only preload the driver but I needed to state the driver type in BOTH the text box as well as the pre-load combo box. After I did that, the drivers seem to be able to work. Thanks everyone for your help.

Hi alex,

I’ve seen your post regarding connection with oracle database and I’ve followed your procedure using the following value.
DB URL: jdbc:oracle:thin:@localhost:1521RCL
DB Username: user
DB Password: password
DB Driver: oracle.jdbc.driver.OracleDriver

But when I test my connection it returns an error.

Could not connect: java/sql/Savepoint

I’m new with Webmethods, I really appreciate your help me with this one.

Thanks.

Hi,

the error Could not connect: java/sql/Savepoint occures when you use the Oracle Driver ojdbc14.jar with older jdk version 1.3 or lower.

Dado