New to WebMethods and getting an error

I am new to webmethods and I am receiving the following error:

The description for Event ID ( 0 ) in Source ( webMethods ) cannot be found. The local computer may not have the necessary registry information or message DLL files to display messages from a remote computer. The following information is part of the event: Service cannot start because LOCKFILE exists <80>

Could anyone tell me why i’m getting this error when i’m starting up webmethods?

manually delete the LOCKFILE file located at C:\webMethods6\IntegrationServer

and re-start the IS

the LOCKFILE is there to ensure you don’t accidentally have IS running twice. However, if IS crashes or is killed without going thru the normal shutdown (which deletes the LOCKFILE), you must manually delete it before it can be run again.

Thanks everyone for you help…I deleted the LOCKFILE and everything worked.

A more permanent fix is to modify the server.bat or server.sh script to neither create nor check for the existence of LOCKFILE. Your IS will still not start if there is one already running and will fail with a port already in use error. The problem is that it will fail only after attempting to perform its normal startup routine which could take several minutes on a loaded down server.

Mark

Not sure how you would do this on the windows platform, but on unix create a shell script to start the webMethods server. The shell script should grab the process id after start and write to file. Every time you run the custom shell script it should check to see if the process id is active, if not have it attempt to delete the lockfile (in case of a previous bad shutdown) and then start the server.

markg
http://darth.homelinux.net