new installation of IS will not start

I’ve uninstalled and completely deleted my previous version of wM, then re-installed (with no errors) wM IS build 132 on my win XP machine.
When I start IS, it initializes for a minute or two, when it gets to the “2005-04-14 09:00:23 PDT [ISS.0028.0001C] Loading packages”, the IS process quietly dies.

Upped the debug level to 10, but it gives no trace of any errors during startup. I’ve set the JAVA_MAX_MEM to 512M just in case.

Any ideas on where to go with this?


Hi John,

It will die if it can’t allocate a listening port. If 5555 is already in use by XP, for instance (though you would see this in the logs).

Does the JVM core? You would see a .txt or .log file in the <wm_home>/IntegrationServer directory.

At level 10 you see no errors, but what do you see? What’s the final set of messages (or ‘loading package XYZ’ message)?

Finally, it will kill itself if you try to start it from the command line but it is already running as a system service (depends on your installation selections). Under this condition you might be manually deleting the LOCKFILE without realising it’s running as a service. If this is the case, you may have introduced a corrupt doc or audit store so I’d suggest you refer to the Advantage Technical Article on this topic for more details.


Also two things, did you delete any remaining folders and/or databases that referenced the old IS and did you do any after install modifications to the new IS besides the memory increase like port number changes. The memory should never be an issue to a fresh IS install no matter how many packages you include with it. Good day.

Yemi Bedu

There is no core dump nor txt/log file pointing to any error under <IS_HOME>, just the standard “SP” and “FP” readme files.
With debug level set to 10, the the IS start only gets to “Loading Packages” and dies, it even removes the LOCKFILE when it dies. It does not load any packages.
IS is running as an application, not a service.
I have tried removing ServiceChace as well as WmRepository2 and 4 files.

But it still dies at the same place.

I have removed the entire old wM directory prior to installing, so there is no reference to old stuff.

I have since removed and reinstalled several times, and am still not able to start it.

Really strange…


I heaved such a problem. Server writes to log �Loading packages� and then stop running.

The problem was in some of our custom written packages. First I tried to copy whole packages folder from old instalation and server stop to loading packages, then I exported all packages which I need from old installation and installed to new server.

If you don�t have old installation, first install fresh copy of WM and try to run server without custom written packages, then try to add your packages one by one and to see where the hang is.

It is possible to have a problem with supplied from WM packages. Just try minimum installation, and then add one by one.

Krasimri Zlatev


sounds like one or more manifest.v3 files are damaged and IS is not able to parse them for checking dependencies between packages. Check your console output as well as the error-log file for any entries related to this. There should be a message which package has the problem.