New cockpit application throws error

I am trying to create a new application from the cockpit template.

The process I went through is the following:

command line:

c8ycli new
? Enter the name of the project: my-app
? Which base version do you want to scaffold from? 1015.0.389 (latest)
? Which base project do you want to scaffold from? cockpit

The project gets created successfully and I can run npm i without getting any errors.
Executing npm start also launches the application without any errors in the console.
The only modification I did to the project is, that I changed the “start” script in the package.json ( “start”: “c8ycli server -u https://my-domain”).

But when I try to open the application, the site is not functional and i get this error in the console.

I have already tried different versions for the cockpit, but i get the same result.
The error only occurs when I use the cockpit template, i tried the empty app and tutorial template, these work without any errors.

Used Versions:

BACKEND: 1015.0.278
UI: 1015.0.317

c8ycli: 1015.0.368
Angular CLI: 16.0.0
Node: 16.20.0
Package Manager: npm 8.19.4
OS: win32 x64

Angular: 12.2.14
… animations, common, compiler, compiler-cli, core, forms
… language-service, localize, platform-browser
… platform-browser-dynamic, router, service-worker, upgrade

Package/ Version
@ angular-devkit/architect 0.1202.14
@ angular-devkit/build-angular 12.2.14
@ angular-devkit/core 12.2.14
@ angular-devkit/schematics 16.0.0 (cli-only)
@ angular/cdk 12.2.13
@ schematics/angular 16.0.0 (cli-only)
rxjs 6.6.7
typescript 4.2.4

I can reproduce this error, but I also find that c8ycli build, then zipping and uploading the ‘dist’ directory creates an application that can be used.

Can you use this as a workaround?

I’ll raise this as a problem with R&D.

1 Like

I can confirm after uploading the failing application, the app works when uploaded and also works when started locally after that.

I will use this workaround in the meantime.

This was fixed with versi0on 10.16.

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.