mws cannot enable process

Hi All,

MWS->administration->Process->Business Process->“select process”->edit
Always got
[exception.wm_bam_process_config_details] Your last action caused an exception to occur while executing getProcessModelFromWS(). The details for that exception follow java.net.SocketTimeoutException: Read timed out. The stack follows: com.webmethods.caf.wsclient.proxy.impl.WSClientDynamicProxy.java:397

Problem happened after applying fix PRT_7-0_SP2_Fix8.jar, problem still presist after fallback the fix.

Anybody faced this issue? Please help on this, thanks in advance.

Alternatively you can use service “wm.prt.monitor:setModelEnabled” to enable the model. You need to provide the Moldel ID and version as inputs of this service to enable a particular model.

PS : Please check if the there should not be mutliple process model deployed with the same name but different model ID’s. If you want to change in any process model, always maintain the uniqueness of model ID or else change the version.

-nD

Hi All,

Iam having some issue while enabling the procee Model in MWS.

  1. Iam able to create build and then deploy.

  2. while enabling Iam getting an error as Your ““last action caused an exception to occur while executing saveProcessModelToWS(). The details for that exception follow SOAPException””

  3. I tried to enble from the developer using the service,model is enabled but I see use satate as NO,when I tried to test the process model is not initiating.

is any one faced this issue, appriciate your help on this.

Thanks in advance…

Are you getting any error on server log, if so please send post it here.
Meanwhile try to relaod wm.prt package and try again.

How long does it take between you click and you get the timeout?

If I recall correctly, services taking over 30 seconds to response will get this error. MWS uses a WS client for communicating with IS, and if service takes too long then…

Can’t remember now how to increase the timeout… nevertheless it might be you have millions records in the database?

I’m running into the same problem error in my environment after applying this set of patches. However, our process enabled and execute. I should note this only happened in one of our environments and not the other.

I did see in another thread with the same error message the user shutdown the MWS cleared the temp dir and restart the MWS. This fixed his issue. Not sure if that is the case here.

From the looks of the error in our environment the MWS didn’t create a table correctly. I’m currently looking into and might be opening a low severity support incident. I’ll post the results if I do.

Even I had the same problem wm 7.1 mws, i got the model to work in a rather unorthodox way not sure about the root cause though:

  1. Deleted the packages created by the Designer in developer.
  2. Changed the model name and built and uploaded it again in Designer 7.1.
  3. I then enabled the model in mws and it got enabled.

Can anyone help us with a root cause for this issue ???