MQ Listener Failed to connect

version : webSphere MQ Adapter 6.5

MQ version : webSphere MQ 7.1

I am successfuly able to do WebSphere MQ Adapter server connection to MQ Queue Manager. but getting exception when enabling the listener.

[ART.115.3257] Adapter Runtime (Listener): Exceeded max retries. Shutting down listener MQListeners:Outbound. Error: com.wm.adk.error.AdapterConnectionException: [ADA.600.1055] Exception caught Listen : Queue could not be opened for Input; com.ibm.mq.MQException: MQJE001: Completion Code ‘2’, Reason ‘2085’

Please Advise

MQ Exception 2085 means MQRC_UNKNOWN_OBJECT_NAME
Queue object name that you supply is invalid.

-Senthil

Hi Susheel,

First of all your connection is enabled?
Secondly are you using temporary dynamic queues in MQ when connecting your client?

Cheers,
Niteesh

@Senthil,

I verified the ‘MQRC_UNKNOWN_OBJECT_NAME’, when I created the MQ Adpater server connection, I could able to view the queues on IBM MQ and matched the naming convention.

So, i ruled out incorrect name…

Niteesh,

The server connection is enabled and succesfully connected. Verified the object authorities on queue and is selected for get and put services. Still the exception, when tried to peek is reason 2085

May be try this option if haven’t:

On the queue manager side give ‘setall’ permission.

It works after giving the privilege “setall” over the QMgr (not over the Qs) to the user. MQ documentation says the privilege “setall” does not apply to the Queue Manager itself, only to the Queues. After remove the additional privileges given before to the user for testing, it still works fine, the user has the privileges: - inq, connect, dsp and setall, over the queue manager itself. - get, browse, put, inq, dsp, passid, passall, setid, setall and clr over the Queues and it’s backout Queue.

Following property change helped in resolving the issue.

[h=2]When creating a Queue Manager in WebSphere MQ v7.1, channel authentication records are added by default. The goal being to provide more precise control of remote systems via the MQ Channel. Subsequently, when testing a Queue Connection Factory in the admin console you could get the following error: [/h]A connection could not be made to WebSphere MQ for the following reason: JMSCMQ0001: WebSphere MQ call failed with compcode ‘2’ (‘MQCC_FAILED’) reason ‘2035’ (‘MQRC_NOT_AUTHORIZED’).
To correct this error check, first connect to your queue manager from the command line:
runmqsc QM_MDB [where QM_MDB=%QUEUE MANAGER NAME%]
5724-H72 © Copyright IBM Corp. 1994, 2011. ALL RIGHTS RESERVED.
Starting MQSC for queue manager QM_MDB.

Then display the channel status:
DIS QMGR CHLAUTH
AMQ8408: Display Queue Manager details.
QMNAME(QM_MDB) CHLAUTH(ENABLED)

and finally, for the fix, disable it if it is enabled
ALTER QMGR CHLAUTH(DISABLED)
AMQ8005: WebSphere MQ queue manager changed.

Glad you got it resolved…thanks for sharing this forum with end resolution.

BTW,Where did you find that info from goog?