MQ Adapter Get Service isn't working !!!

I am trying to get a message from MQ using the MQ adapter get service.

Please find below the platform details:

MQ is running on OS390 (ZSeries) mainframe system, version 5.3.

webMethods IS is running on Windows 2000 Server, version is 6.1, and MQ adapter version is 6.0.

When i try to execute Get service, i am receiving the following error:

MQJE055: The queue manager does not support version 2 MQSeries API structures.
Completion code 2 and Reason code 2186.

After some investigation, i gather that changing the ‘version’ data might solve the problem. But i do not know how to modify the version information from webMethods Get service.

I am not sure if there is any problem with the MQ jar file i am currently using. I have also tried using few other mq.jar versions but i am constantly hitting the same error.

Any help in this regard is greatly appreciated.


Please make sure to apply MQ Adapter 6.0 fixes 1 through 10. This is certainly a pre-requisite. We had issues with MQ adapter 6.0 without any fixes in place. We are in the process of investigating to use MQ adapter 6.0 and will let everyone know of known issues and workarounds later if you are interested.

Good luck,