Missing IDocs ("Confirm action for nonexisting Transaction TID..." error)

Hi - I have a 2-node webMethods IS 8 cluster connected to SAP ECC using the SAP adapter. The IS cluster has the SAP adapter ‘Centralised Transaction Store’ (CTS) function enabled.

I stumbled upon an extremely intermittent issue where IDocs sent from SAP to webMethods simply don’t reach webMethods, though SAP thinks they have.

The only trace of a missing IDoc is a mention of its transaction ID (TID) in webMethods server log that states: “Confirm action for nonexisting Transaction TID…”

Example:


2011-12-22 11:02:41 EST [SAP.0103.0011I] Creating ART connection to alias "sap" in partition "ECT&%EAI...": com.wm.adapter.sap.spi.SAPConnection
2011-12-22 11:03:50 EST [SAP.0103.0023E] IS Session "null" does not exist.
[b]2011-12-22 11:03:50 EST [SAP.0110.0039W] Confirm action for nonexisting Transaction TID "0AE60321735D4EF273E31974"[/b]
2011-12-22 11:03:56 EST [SAP.0103.0014I] Destroying ART connection to alias "sap" in partition "ECT&%EAI...": com.wm.adapter.sap.spi.SAPConnection

Checking the TID in SAP (SAP transaction se16, set table EDIDS, enter in the TID value and execute), it looks OK. It has status text: “IDoc sent to SAP system or external program”

The error (“Confirm action for nonexisting Transaction TID …”) indicates webMethods is complaining about SAP confirming a TID webMethods knows nothing about. Does anyone have any insight about how TIDs are used in IDoc exchange?

I’ll raise with webMethods TS as well, but has anyone got a suggestion that may shed some light on this issue?

The problem is extremely rare (95 instances in several months and tens of millions of outbound IDocs).

We are facing the same issue on our webmethods 8. If you have solved this, could you tell us how?
Thanks a lot, David

We solved it by increasing the Max Pool size in the SAP connection from 1 to 200. This solved our problem. Thx anyway.

Sonam,
Are you running any type of schedule to delete your transaction store? If so, are you using the pub.sap.transaction:deleteAll service or the pub.sap.transaction:sweep service with no inputs. In either case when the schedule runs it will delete all transactions in any state and may delete a TID that is in process. I recommend running pub.sap.transaction:sweep and setting the state parameter to Confirmed. Hope that helps.

we’re facing the same issue in WM6.5, we didn’t use cluster, connection max pool size was set to 10 by default, used pub.sap.transaction:sweep to clean transaction store regularly, also set transaction status to ‘Confirmed’ or ‘Commited’. Not sure if there is any other factors caused the IDOC missing, anyone could give some suggestion? Is there any method to detect IDOC missing except for regular reconciliation? :?

I checked few missed IDOCs, only one of them have below error in webmethods SAP adapter log, all the rest have no error message, cannot find any related log in EAI side, however, all they’re in status 03(passed to port ok) in SAP side.

Error msg:
2013-07-12 08:39:16.785 CEST [SAP.0110.0039W] Confirm action for nonexisting Transaction TID “87785CE254E051DFA4550BA2”

Jenny,

Did you try increasing max connection to 100 or some thing on the Adapter connection? It’s worth give it a shot.

I do not see this issue in SAP Adapter71 though.