Messaging Trigger is not triggering the Subscribe service

I have an integration where the publishable document is used by multiple subscribe services. I am required to design a new subscribe service which will require to add new fields to the publishable document.

I added new fields to the publishable document and performed the appropriate mapping. Then I have sync’ed the same with universal messaging through both our IS Servers.

However, now the none of the subscribe services get triggered and no error is seen while publishing the updated document as well.

Anyone could help on why the services may not get triggered due to changes to the publishable document.

Thanks,
Ruturaj

I assume you don’t have any trigger or provider filters, your triggers (retrieval and processing) are not in suspended mode, and your published message is actually going to UM (i.e., not to the CSQ).

Go to one of your trigger clients via Enterprise Manager (EM) and enable snooping. Publish the document and see if you see an entry in the snoop list.

If there are no messages in snoop, then -

  1. Disable ALL relevant subscribing triggers via Designer
  2. Delete the corresponding trigger client objects from UM via Enterprise Manager (EM)
  3. Make the DocType “non-publishable” on BOTH nodes
  4. Make them publishable again
  5. Ensure that the latest DocType is “in sync with provider” across both IS nodes
  6. Enable the triggers again via Designer
  7. Check if trigger clients are “connected”, on EM
  8. Enable snooping again
  9. Publish a message and check if it’s snooped now

If it’s still unresolved, provide your IS version and fix level.

I typed this response from my phone, ignore any mistakes.

Hi Kasi,

the above did not work. Below are my observations.

yes, I am using filters provider filters and triggers are in active state.
But, if I run the package without any changes, the pub-sub works correctly(old and new subscribe service triggered as expected).

However, once I edit the publishable document with new fields and sync the document through both IS, the subscribe service(both old and new service) fails to trigger.

IS Version - 9.10
fix details - IS_9.10_Core_Fix4

Thanks,
Ruturaj

Try removing all the filters and then perform your Document Type changes - does it work post-changes, when there’s no filter?

Either way, you are several fixes behind - install all latest fixes for IS and UM (well, preferably for all your products) and see if that resolves the issue.

Typically, there’s only less than minor chance that you are uncovering a NEW undiscovered defect, especially in a version that has been GA for a few years - most issues would’ve been resolved already, so I strongly recommend fix updates as your first step. This will save your time from rediscovering something that has been solved already.

KM

1 Like