Looping data from dbms


I have some problem for looping data from data base. I used the %loop% syntax but it still doesn’t work.

I used the adapter service to select table from oracle dbms,in developer I can run this adapter and it running successful.

After that I made dsp for client, but when I tried to made it, I can’t Invoke and looping this data.

Is there somebody can help me …

how did you write your %loop% ?

One Example from me: The Adaptor-Service has the output: SteuerDaten_ASOutput/results
%loop SteuerDaten_ASOutput/results%
%value SomeValue%

Hope that helps

For Exsample I have Adapter Service name Viewdata in package Exercises.
The Output from this adapter is “ViewdataOutput”.
And I run in developer the result is array string from table. shown like below:

      |-FIELD1 : abc 
      |-FIELD2 : 123 
      |-FIELD3 : xxx 
      |-FIELD4 : yyy 
      |-FIELD1 : abc 
      |-FIELD2 : 123 
      |-FIELD3 : xxx 
      |-FIELD4 : yyy 

is the dsp code like this?



%invoke Exercises:Viewdata% 
%loop Exercises_Viewdata/results% 
%value FIELD1%
%value FIELD2%
%value FIELD3%
%value FIELD4%