Logging in local users with SSO configured

What product/components do you use and which version/fix level are you on?

Cumulocity 10.13

Is your question related to the free trial, or to a production (customer) instance?

Production (Adamos)

What are you trying to achieve? Please describe it in detail.

On the tenant SSO is configured but local users exist as well. Newly created local users can login once after resetting their passwords but afterwards logged out users are always redirected to the SSO provider. Is there a direct link to the standard login page of Cumulocity available that does not redirect?

Hi Harald,
depending on how SSO is configured this can coexist.
Hence I believe in your setup SSO is enforced which does not allow user/password authentication?
By default it would be possible to still show the login page and allow SSO users to click the SSO button to use SSO.

Edit:
See Single sign-on redirect setting in Administration - Login Settings

Regards Kai

Specifically, “Preferred login mode” should not be SSO to allow users to select between local login and SSO login.

1 Like

You can login with native user when SSO redirect is activated.
(Preferred login mode = “single sign-on redirect”)
From 10.6.0.14, 10.6.6.8 and 10.6.12.0

  • modify the subdomain to something that doesn’t exist,
    e.g. https://xyz123.cumulocity.com
  • This provokes the native login screen to show up with the Tenant ID login
  • Add tenant ID and log in
  • Administration – Settings Authentication
    Now you can change preferred login method.

Thank you Christian, that works as well!