Logger Adapter Problem [1]

I’m having problems getting the Logger Adapter to work. I’ve installed the Enterprise Adapters (v4.1.1), Adapter Development Kit (Runtime)/
webMethods Enterprise Adapter Manager and the
Enterprise Integrator Adapters.

After going through pages 161-168 in the Enterprise Integrator User’s Guide version 4.6,
I get a dialog with the following message:

Could not restart the webMethods Enterprise
Adapters.

No configuration for adapter process
“EntLogger” on broker “Broker #1@system1”

Also, I don’t have the ent_logtables_mssql_create.sql file.
What package do I need to download to get this
file?

Make sure you have an adapter configured named EntLogger. Create this using the Adapter Manager tool. Then execute the sql to create the logging tables. You can usually find them under
C:\Program Files\webMethods\db\scripts\create\create_dbtables_Oracle.sql. Do a search on “ent_” and you will find what you need.

HTH, Tom

Hi,

I m facing the same problem. I configured Logger adapter EntLogger but it gives the same error message. Infact it gives same error for the oracle adapter I configured. I created the table using the sql script provided. Please let me know if you have found any solutions for this.

thanks in Advance
rashmi

Hi,

which version of webmethods do you install? If you install 4.6, you can find script in c:\Program Files\webMethods\db\scripts\create.

Regards,

Chirag.

If you are using adapter manager you need to do the following:
Install the 411 adapter set
Install the EI adapter set
Install adapter manager
Create and start an adapter process monitor
In Enterprise Manager create a client group for the logger adapter
In Adapter Manager create a new adapter instance of type logger
The DDL for MSSQL should be somewhere in your wM directory structure

  1. Does webMethods supports Integration Monitor conection using SQL Server 2000 JDBC Drivers?

I am not able to connect to IM using any JDBCURL and drivers even though JDBC drivers JAR files are in CLASSPATH. Any clues?

jdbc:sequelink://162.138.118.70:19996;databaseName=loggertest

com.merant.sequelink.jdbc.SequeLinkDriver

OR

jdbc:microsoft:sqlserver:://OS-S46857\TMLOGGERPROD

com.microsoft.jdbc.sqlserver.SQLServerDriver

I can connect to a deafult instance in SQL Server 2000 but not to a named server instance.
I have used all possible DBURLs mentione below but it didn’t help.

jdbc:sequelink://162.138.118.70:19996;databasename=loggerprod

jdbc:sequelink://162.138.118.70\tmloggerprod:19996;databasename=loggerprod

jdbc:sequelink://‘162.138.118.70\tmloggerprod’:19996;databasename=loggerprod

jdbc:sequelink://162.138.118.70:19996;databasename=loggerprod;servername=tmloggerprod

jdbc:sequelink://162.138.118.70:19996;servername=tmloggerprod

jdbc:sequelink://162.138.118.70:19996;databasename=tmloggerprod\loggerprod
I am trying to connect to EntLogger using IS administrator.

http://localhost:5555

License verification fails for all database tables when connected to the logger database using web URL �http://appsdev1:5555/EntLogger/�

Service ent_activation:totals
Error class java.sql.SQLException [MERANT][SequeLink JDBC Driver][SequeLink Server]License verification failed.

Try starting your integration monitor like this:

D:\webMethods\Ent5\EnterpriseIntegrator4\bin\integration_monitor.exe -classpath D:\webMethods\Ent4\jdbc\classes12.zip

It’s VERY sensitive about classpath. Also look through the archives, this has been an issue before.

Hope this helps.

W