LOCKFILE in Integrationserver folder

Hi All,

i have sucessfully installed webmethod 8 Suite in win server 2008 and win server 2003, i have installed integration server as a service(services.msc) set the property has automatic, i have started the IS service from services.msc, after some time i have re-booted win server 2008.Observed the IS services is not started automatically, than i was trying to start manually it is given lock file exist .

than i have removed lock file and started the IS service from services.msc.

Observation:while re-booting win server 2008, IS lock file is not removing automatically, becz of this IS is not starting automatically.

is there any -way to resolve this problem.

regards,
anil kumar ellendula

There are some hints if you google for this, example: https://wmusers.com/forum/showthread.php?t=15450.

Hi Anil,

Just like what one of the responses from wmuser forum, the significance of LOCKFILE is to ensure that only one IS starts in the same home directory (although running it as Window Service, might ensure a single instance). And this file lingers if IS is not properly shutdown. Which is good to have if you want to check the possible reasons why IS was not properly shutdown.

  • But should you decide to override this behavior, in addition to what had been mentioned in wmuser forum, you can also disable the lock file by altering the installSvc.bat file.

Below is what you can do:

  1. Make sure to backup ‘/IntegrationServer/support/win32/installSvc.bat’

  2. Change the code in ‘/IntegrationServer/support/win32/installSvc.bat’ file as follows: Remove the section of code “/lockfile LOCKFILE”

/installdir “%IS_DIR%” /workdir “%IS_DIR%” /lockfile LOCKFILE

TO:

/installdir “%IS_DIR%” /workdir “%IS_DIR%”

  1. Un-register the Win Service
    -> /IntegrationServer/support/win32/installSvc.bat unreg (to be executed at command line)

  2. Re-register the Win Service
    -> /IntegrationServer/support/win32/installSvc.bat reg (to be executed at command line)

Hope this helps.

Kind Regards,
Meann