LDAP setup in Centrasite 9.0

I am trying to run the CentraSiteCommand interactively wizard and continue to get usage errors. I am using the following command "CentraSiteCommand set Authentication -url “http://localhost:53307/CentraSite/CentraSite” -user “Adminguy” -password “passname” -file " NOTE: I replaced the localhost with full qualified name but used the book for example. Anyway I just get the following

So do you have a sample of what the command line should actually look like to run this interactively.

Hi Kevin,

to run the command in interactive mode it’s sufficient to run it this way if executed locally on the machine:

CentraSiteCommand.cmd set Authentication -user Administrator -password

BTW: Can you post the error again that you got? It seems it didn’t make it into the forum post.


I am trying to connect to our ldap using Active Directory . After using the wizard and finding the server and validating the acct I proceeded to map our attributes and with error when completed.

[ERROR] Cant get user properties. <0>

Do you want to see the complete trace? (Y/N) [N] :y
E 11:21:37 (0000184cSSXGetUserPropertiesEx_W: SSX Error: Required parameter missing…

Not sure why it is having an issue I checked with our ldap guys and for AD we are not doing anthing unique. Any ideas

Unfortunately there seems to be an issue with the interactive mode of CentraSiteCommand when defining an attribute mapping for AD.

You can use the SsxLdapValidator tool instead. You can download it from empower.

Please make sure that you call the executable jar with a 32 bit java. Your CentraSite installation provides one.

I still have issues here is the error I get when running the command giving it the proper ldap server and then host port. I selected 1 for Active Directory and then when it tries to connect I get a dump see attachement.

I:\SoftwareAG\jvm\jvm170_32\bin\java -jar SsxLdapValidator:

The exception is caused by the fact that your environment variables are not set up correctly. To fix that you need to do the following:

  1. Copy SSXLdapValidator.jar to the bin directory of your CentraSite installation
  2. Execute centrasite_setenv.cmd in the CentraSite bin directory
  3. Execute SSXLdapValidator.jar in the CentraSite bin directory


I’m getting the same error when using the SSXLdapValidator. Were you able to resolve your issue? If so, can you please share what you did to fixed it?