JMS Trigger polling time with Azure Service Bus

Hi guys,

Using Apache QPID I successfully connected my IS to Azure Service Bus. Everything is working fine except that my JMS Trigger is polling messages from Azure Service Bus queue on every 30s. Is there any way to define polling time for this? I need to receive message from queue every second.

Do I need to define some parameter in Extended setting on my IS?

Thanks in advance.

We faced the same issue. Did anyone managed to get this working?
@Prasanta_Malik - Would you be able to help - Integration Server support for AMQP with providers (Azure Service Bus and RabbitMQ) - #3 by Prasanta_Malik

Could you please provide few more details like the type of the trigger, did you explicitly set the primarythread polling interval in extended settings? The polling is always on and if there is no message, the consumer will wait for configured time (which I think is max 3 seconds), so I guess 30 seconds is coming from somewhere else. Did the queue having enough messages when trigger polls for messages?

@srikanth.prathipati1803 Issue has been resolved. In pub.jms:receive you need to set parameter “timeout” to “0”. In that case, service will not wait for a message from JMS Provider (in this case Azure Service Bus). If you want, you can set it to some other value in milliseconds for service to wait for a message.

1 Like

if you can share few details?

  1. which QPID version are you using?
    2.JNDI Provider
  2. example property file (redacted with keys).

Thanks for updating @ilicmarko