JMS trigger is not suspended

Hi All,

JMS trigger is not suspended

I have set the Trigger property, PFB the snapshot.

The service is retried for 3 times siuccessfully and logs are wrriten.
But Trigger needs to be suspended for the above condition but it is enabled.
Kindly help us on this regard.

Note: Resource Monitoring service is set in the trigger (isAvailable = True/False). But Resource monitoring also not invoked here.



Did this issue resolved?
Can you please let us know the what changes done to resolve this.


Can I have a outline of your trigger flow service. Make sure your flow service follows the service outline described in #41 Building Services that Retry in 9-12_Service_Development_Help.pdf

Hi Mahesh,

I have a jms trigger pointing to queue with some filter condition. The subscribing service mentioned in the trigger will do a http call

Messages are picked and lost if the server is down - i.e. http call returns server down.

I’m trying to build a retry mechanism for trigger along with resource monitoring service. Attached is the screenshot of trigger properties.
The service is successfully retrying but trigger is not suspended at the end.
In the resource monitoring service I’m just setting the isAvailable to ‘false’.

Please suggest if I’m missing anything. why trigger is not suspending?


Could you please share the logic for your trigger service. I hope you have provided sufficient hint for Integration server to retry for the transient errors. if not, please use, pub.flow:throwExceptionForRetry to mark an exception as ISRunTimeException.

Note: IS treats all the exception as serviceException.


Hi ,

Logic of my trigger service.

Change the comparison as retryCount<=maxRetryCount as the count will be 0 for both the values in first run.


Thanks Satya. That worked.

I tired this scenario . But , when i try to activate the trigger I get the below error.

Trigger is locked. Change not permitted

Any idea


Now if i change the value of isAvailable=‘true’ and then tried testing it.
It retried and trigger got suspended. For isAvailable=‘true’ trigger should not be suspended?
Is my understanding right?


Hi Satya,

Trigger locking could be because of ACL issue.

I guess the service is not avaialble again so it got suspended. Are you hardcoding it as true ?


  1. The resource monitoring service is custom built and is optional.

  2. The resource monitoring service provides output (isAvailable=true) when the required resources for processing are up and running.

  3. Once the resouce monitoring service provides the necessary hint for the Integration Server to resume(isAvailable=true), IS changes the trigger state from Suspended to Active.

  4. Trigger State ( suspended) happened on account of retry mechanism is temporary.

  5. In cluster environment, suspension of trigger in node has no impact on another node…



I had harcoded ‘isAvailable’. Yes Sasanka you are right, the suspension was temporary which was from retry.
How to delete the resource monitoring thread.
I had removed the entry from trigger properties, but still i could see the task running under system tasks and also could see messages on server log.


I tried to implement same logic but getting below error.

[178]2018-05-21 16:59:06 IST [ISS.0134.0042E] JMS Trigger fOLDER:jms_trigger failed: com.wm.lang.flow.FlowException: [ISC.0049.9009] Missing required property switch at ‘unlabeled BRANCH’

Any help will be appreciated.

Check your BRANCH evaluate label property. Set it to true if you want branch on the expressions. Else set it to false, if you want to branch on switch value.

Please check Service development guide for details.


Now that error is resolved but i cannot see trigger is suspended. This is my resource monitoring service and configured in trigger. In this service i have configured pub.trigger.resourcemonitoringspec that returns true/false. I make a 3rd party service call and timing out and then bringing up to see if trigger is suspending or not.

Also no system task is created in scheduler.