JMS: Broker protocol error: 71

Hi All,

Has anybody seen “JMS: Broker Protocol error: 71” when publishing documents to a JMS Topic residing on a local Broker that is not the Default?

IS Server.log is showing:

[375]2008-12-23 11:08:17 GMT [ISS.0134.0016E] JMS Connection Error on connection “jrhJMS”: javax.jms.JMSException: [BRM.10.4042] JMS: Broker protocol error: 71
[377]2008-12-23 11:08:17 GMT [ISS.0134.0026E] CSQ Dispatcher “jrhJMS” was unable to send message to “jrhPackageDeployment_1” after 5 retries: javax.jms.JMSException: [BRM.10.4042] JMS: Broker protocol error: 71
[376]2008-12-23 11:08:17 GMT [ISS.0134.0054I] Stopping all triggers associated with JMS Connection Alias jrhJMS.

If the configuration is changed to use the Default broker this works without error on both Windows Vista and Solaris 10 installations.

I even tried copying the Broker document definition of the document being published from the default broker to the non-default one but this has not helped.

Has anybody got any ideas what I might have forgotten to do?



Hi all,

Just to close this thread off and document the solution in case anybody else hits this - Software AG Support pointed me in the right direction.

The problem isn’t related to default or non-default brokers, but was instead down to me having set Validation to Full when creating the Document Type in MWS. Once I changed this to None it worked fine.

Disappointing that Full is the default and that the error message is less than helpful but there you go…

Cheers all. John

Thanks for the update…But why with changing to default worked? any word on this from SAG support?


I must have had no validation on the default broker…

I now have it working on a non-default broker.

But the validation is also none but still i got the above exception errors and the trigger got disconnected also.
How to carry on with this… Please suggest me