JMS Adapter Issue connecting to weblogic

I need help resolving a problem connecting to one of our clients weblogic queues using JMS adapter.
We are in the process of upgrading from wm6.5 to wm7.12 and would like to make a little as possible code changes. So we are trying to still use the JMS Adapter in 7.12 and will move over to the build in JMS functionality later.
I have been able to get all the JMS connections up and running except for connections to weblogic.

the setup is as follows :
connOSM Details
Connection TypeJMS Adapter QueueConnection
Package NameTESTConnection Properties
Transaction TypeNO_TRANSACTION
JNDI Initial Context Factoryweblogic.jndi.WLInitialContextFactory
JNDI Provider URLt3://
JNDI Security Principal
JNDI Security Credentials******
JNDI Other Properties
QueueConnectionFactory JNDI Namemslv/oms/oms1/internal/jms/ConnectionFactory
JMS user
JMS password******
Connection Management Properties
Enable Connection Poolingtrue
Minimum Pool Size1
Maximum Pool Size10
Pool Increment Size1
Block Timeout (msec)1000
Expire Timeout (msec)1000
Startup Retry Count0
Startup Backoff Timeout (sec)10

When i try and activate this i get the following error :
Error encountered
[ART.118.5042] Adapter Runtime (Connection): Unable to enable connection resource connOSM.[ART.118.5036] Adapter Runtime (Connection): Unable to configure connection protocol:
I have installed the following fix :JMS_6-1_Fix12
I have tried moveing the weblogic.jar to the WmJMSAdapter/code/jars directory but still no luck.

Any suggestions?

Try moving weblogic.jar to /lib/jars instead. Ensure you have wlclient.jar and wljmsclient.jar in this directory as well.

You have JMS_6-1_Fix12 installed - I take it you created WmJMSAdapter_jaas.config as instructed in the readme? Also that you modified as instructed?

There should be no files in packages\WmJMSAdapter\lib

remember to do a cold restart of the IS after any of these changes.

Hope this helps.

P.S. - going through the same issue at present, got it working on Windows, but not Linux…

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.