JDBC connection problem

I am trying to establish a JDBC connection the connection properties are
Connection type:JDBC Adapter Conenction
Package name :Exercise1
transaction type: NO_TRANSACTION
Datasource class: Oracle.jdbc.pool.oracledatasource
databasename: home
port number: 1521
network protocol:tcp
other properties: driver Type = thin

The errors that i got are
Adapter runtime connection :unable to enable connection resource r:exercise1
Adapter runtime connection :unable to configure connection manager.
The JDBC data source class"oracle.jdbc.pool.oracledatasource" cannot be located.

I have already copied the classes12.zip file in the integration server\lib\jars
and I have also unzipped the file and checked for the oracledatasource.class file and it is present.

please help me to solve this problem.

After copying the zip file, did you restart IS?

Thank you for the reply, I tried that but still it says the same thing

I should have noticed this before. The error message (which I assume you copied and pasted from Administrator):

The JDBC data source class"oracle.jdbc.pool.oracledatasource" cannot be located.

The classname is case-sensitive and should be oracle.jdbc.pool.OracleDataSource

Also, if you’re running a 1.4 JVM you might consider using ojdbc14.jar instead of classes12.zip (which is for a 1.2 JVM).

thank you very much I will try that…

I have tried that but still I am getting the same thing that previously used to come there is no change.please help

I think Rob was on the right track. The class name for your data source is case sensitive and cannot have spaces in it - you should double check that. Often when pasting an extra space gets tacked onto the end of the class name.
The class is loaded into the JVM at start up, so any time you put a new jar into your lib/jars folder, you must restart the IS to pick it up. And finally, to confirm you have the right class name, you could open the zip file with a zip utility and you should be able to navigate through the folder structure that matches your classname. Before doing that however, I would recommend you copy the zip file to a local directory so that you do not accidentally modify the one under your Integration Server install.

Hi ,
I m getting this error when i m creating JDBC connection…
Can anybody help me to solve this issue??
[ART.118.5042] Adapter Runtime (Connection): Unable to enable connection resource CUSTOMERMANAGEMENT_ANITA:JDBCConnector.
[ART.118.5036] Adapter Runtime (Connection): Unable to configure connection manager.
[ADA.1.204] Cannot connect to the database with DataSource class “oracle.jdbc.pool.OracleDataSource”.
Invalid Oracle URL specified: OracleDataSource.makeURL

Can you post your JDBC Adapter connection properties that you have currently in place.


The highlighted portion of the error message is what you’ll need to research and resolve.

Hello all,

The issue is solved… it was with driverType=thin.:slight_smile:

hi to every one…
i was also got same problem …

now i solved my problem…
Thanks very much to every one…