JDBC Adapters Connection setup error: "Invalid Oracle URL specified: OracleDataSource.makeURL"

I’ll be using Oracle Express Edition 11g as my database. Upon trying to enable the connection, I get this error:


Error encountered [ART.118.5042] Adapter Runtime (Connection): Unable to enable connection resource adapters:examEventsConnection.
[ART.118.5036] Adapter Runtime (Connection): Unable to configure connection manager.
[ADA.1.204] Cannot connect to the database with DataSource class “oracle.jdbc.pool.OracleDataSource”.
Invalid Oracle URL specified: OracleDataSource.makeURL

Transaction Type: LOCAL_TRANSACTION
DataSource Class : oracle.jdbc.pool.OracleDataSource
serverName: localhost
user :
password : ******
databaseName:
portNumber: 1521
networkProtocol: tcp
Other Properties: thin

Inside Z:\SoftwareAG\IntegrationServer\packages\WmJDBCAdapter\code\jars, I have ojdbc6.jar file stored.

How can i fix this?

Hi,

No issue with jar file as it is loaded properly.

Some issue with your connection string. Please provide Other Properties as below :

Oracle Thin Driver:
driverType=thin

OR

Oracle OCI Driver
driverType=oci

Thanks,
Yogesh

1 Like

I’m doing it now. I receive the same error unfortunately.

Please share your updated connection string

Hi,

Yogesh is right regarding the driver type.
I would prefer thin mode as this runs without additional native libraries.
OCI-mode requires addtional native libraries and has a reduced performance over the thin mode.

Oracle Express Edition has a fixed database name of “XE” which cannot be changed.

Depending on your IS version you should consider upgrading your driver jar to ojdbc7.jar when running IS in Java 7 or newer.

When the error message persists check all the fields in the connection setup for leading or trailing spaces.

Regards,
Holger

Transaction Type LOCAL_TRANSACTION
DataSource Class oracle.jdbc.xa.client.OracleXADataSource
serverName localhost
user
password
Retype password
databaseName
portNumber : 1521
networkProtocol : tcp
Other Properties : thin

Also, I am using Oracle SQL Developer (if this is relevant).

Hi,

as already pointed out above, you should adjust your settings as follows:

databaseName XE
Other Properties driverType=thin

Additionally check your connection for the required transactionality.

LOCAL_TRANSACTION requires a different DataSource class than XA_Transaction and you have specified the XA-DataSource for your LOCAL_TRANSACTION.

Either:
Transaction Type LOCAL_TRANSACTION
DataSource Class oracle.jdbc.pool.OracleDataSource

Or:
Transaction Type XA_TRANSACTION
DataSource Class oracle.jdbc.xa.client.OracleXADataSource

Regards,
Holger

Hi Please remove all parameters, and provide the url in other properties as below:-
driverType=thin;url=jdbc:oracle:thin:@(DESCRIPTION=(ADDRESS=(PROTOCOL=TCP)(HOST=******)(PORT=))(ADDRESS=(PROTOCOL=TCP)(HOST=)(PORT=))(LOAD_BALANCE=yes)(CONNECT_DATA=(SERVER=DEDICATED)(SERVICE_NAME=)(FAILOVER_MODE=(TYPE=SELECT)(METHOD=BASIC)(RETRIES=180)(DELAY=5))))

Hi Shrinidhi,

I consider this a bit complicated way as this an Oracle Express Edition with limited functionality.

Here is the complete, commented parameter list:
Transaction Type LOCAL_TRANSACTION (does not match with DataSource Class)
DataSource Class oracle.jdbc.xa.client.OracleXADataSource (does not match with Transaction Type)
serverName localhost
user
password
Retype password
databaseName XE (needs to be added, was missing in the original post)
portNumber : 1521
networkProtocol : tcp
Other Properties : driverType=thin (changed from “thin” to “driverType=thin”, to inform the driver that this is meant to go to the driverType parameter)

For further informations check the previous replies to this post.

Regards,
Holger