JDBC Adapter Synonym Support

Does this JDBC adapter 6.01 support the “synonyms”??

I am trying to access one of these but i dont see them listed in Developer under selection drop down list, when i tried to create the notification event any help will be great!!!

It has been my experience, while creating adapter services, that synonyms are not supported. You have to choose the schema where tables exist not the schema that shows synonym.

I would like to be proven wrong on this if you have gotten any additional information.

I found a posting on the wM Advantage site that explains why synonyms do not work, which I have attached below.

Does anyone know of an Oracle JDBC Driver that does support synonyms? The Custom SQL work-around provided below is not desirable.

I’m using enterprise JDBC Adapter 4.6 and connecting to an Oracle DB. When trying to configure an ‘Insert Operation’ on a synonym, I can see the synonym name in the drop down list of tables, and I’m able to select it. However, the “Insert” tab does not show any columns. Why don’t the other tabs get populated for synonyms in the same they get populated for normal tables?

The problem that you are facing is a limitation in the driver, which in this case would be the Oracle native driver (classes12.zip). The adapter is not displaying the fields in the ‘Insert’ tab because the driver doesn’t support this functionality and the adapter is just a generic interface to the driver. The drivers do not implement methods (DatabaseMetadata.getColumns()) for getting column information for synonym, though they do implement methods (DatabaseMetadata.getTables()) to get synonym names. This is why the adapter can automatically provide synonym names, but not synonym columns. We have seen this limitation in both the Oracle and Informix native drivers.

However, you can use CustomSQL configured operation to work with Synonyms.

Hi Prasad,

I too faced the same problem and webMethods said that its the limitation with the Driver. But when I have gone through the Driver documentaion for the function (DatabaseMetadata.getColumns()) when we set the property “includeSynonyms” to “TRUE”, then the function returns even the columns when we pass the Synonym as input. Iam in the process of testing this stuff.

If anybody has tried this, please let me know.


Hello All,

Curious to know if anyone has had any success interacting with Oracle Public Table synonyms using the 6.0.3 JDBC adapter. I’m running IS version 6.5 with the 6.0.3 FP1 JDBC adapter. Using the latest 10g release 2 Oracle JDBC driver and using the includeSynonyms property setting, I can see the table in the templates dropdown. However, as soon as I try to add colums or view any column inforation, the adapter template throws errors.

Any ideas?