JDBC Adapter Connection

Hi

I want to create JDBC Adapter connection. I used “com.dd.jdbcx.sqlserver.SQLServerDataSource” datsource calss.
When I try to enable Adapter connection it gives error: Data source class not found.

Can anyone answer why this error is comming and solution for this error.

Thanks in advance. :slight_smile:

Make sure you place the jars file within Integration Server/WmJDBC adapter. What is your IS version? What type of database are you trying to connect?

Refer webMethods_Adapters_System_Requirements

Hi There,

I guess you are using SQL server DB. In case yes, instead of using “dd” try to use “ddtek” in “com.wm.dd.jdbcx.sqlserver.SQLServerDataSource”. If you still get the error change from XA_TRANSACTION to LOCAL_TRANSACTION. Please try the above options and let us know result.

Thanks,

Hi
I tried the above option. However it is not working.

As I suggested earlier install the required jdbc drivers.

Hi Niraj,

Did you encounter any errors after changing details as I said and if yes kindly share the logs to better suggest to get rid of this issue.

Thanks,