JDBC Adapter configuration Error IS601

I am getting the Error shown below,while configuring new JDBC Adapter connection:

Error encountered
[ART.118.5042] Adapter Runtime (Connection): Unable to enable connection resource OraConnracleCon.
[ART.118.5036] Adapter Runtime (Connection): Unable to configure connection manager.
[ADA.1.200] The JDBC DataSource class "oracle.jdbc.pool.OracleDataSource " cannot be located.
oracle.jdbc.pool.OracleDataSource .class not found

I have also tried with:

Database trying to connect :oracle 8i
Copied classes111.zip,classes12.zip in to IS classpath.

And successfully connected and configured wmDB via Alias and able to execute query,but not success in JDBC Adapter configuration.

Kindly help me with solution,Appreciate your help,


Please go thru the following details…and make sure classes12.zip in the IntegrationServer classpath…

Still you don;t get this fixed, there are many early discussions on this topic, where you get more by searching on JDBC Adapter topic.


JDBCAdapter:TestJDBCAdapter Details
Connection Type JDBC Adapter Connection
Package Name JDBCAdapter
Connection Properties
DataSource Class oracle.jdbc.pool.OracleConnectionPoolDataSource
user scott
password ******
databaseName GDBREP
portNumber 1521
Other Properties driverType=thin
Connection Management Properties
Enable Connection Pooling true
Minimum Pool Size 1
Maximum Pool Size 10
Pool Increment Size 1
Block Timeout (msec) 1000
Expire Timeout (msec) 1000

Thanks GV,

It was solved no probs,we made some mistake while defining the JDBC test package in developer.

Assuming your ID/password are fine… then.

You should only need one classes***.zip file. Download for whatever connection type you are using.

Also, use oracle.jdbc.pool.OracleDataSource if you are using classes12.zip. 's oracle.jdbc.driver.pool… for classes111.zip

Thanks Randy,Its now working pretty much fine.

Lets close this thread…