Issue with JVM settings on wM8.2

Hi Guys,

I’m trying to set JVM settings on IS server.bat

but my settings are not implemented. i checked statistics page. i don’t see increase in memory.

i installed wM’s as a service. Before i make the jvm settings, i unreg the service and made jvm settings and then registered the service. But new JVM settings are not initiated.

Can you please help?


Any Help??

I think they moved to a separate file didn’t they? I can’t remember where, but I think it was ignoring the “usual” place for setting things and looking in another file for the jvm params.

Nathan Lee,

By default, IS JVM memory can modify from setenv.bat but it’s also possible to
modify memory setting straight away from server.bat by replace this line in server.bat to their respective value.

SandeepKumar ,

i have did the steps you mentioned above and i am able to modify my IS JVM memory successfully. FYI, i am trying on WM8.2 as well.

  1. Uninstall IS service
  2. Replace
    set JAVA2_MEMSET=-Xms512M -Xmx512M -XX:MaxPermSize=256M -Xrs
    in server.bat
  3. Install IS service

Sorry, i changed the setting on setenv.bat itself. JVM settings are not applied.

I will try modifying server.bat, thanks.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.