Issue with JDBC connection after DB restores its state

Hi All,

Does anyone faced issue with JDBC adapter services not working after DB restores? Currently, it is requiring to refresh the JDBC connection after DB comes up for properly executing adapter services. It is happening with WM8 version.

Shriraksha A N

Did you go into the JDBC Connections from the IS to ensure your path is the same? The DB server/'s must be listed in there for you connection to work.

Yup, I have been seeing this issue from JDBC Adapter 6.1 till now and for some reason i still can not find one standard solution for this. Different things worked for me at different client implementations.

Things that i have tried in past and helped me in resolving the issue.

  1. Reload the JDBC connection.
  2. Enable and disable the connection.
  3. Create a service which will get all the list of JDBC connections and reload them. Add this service to the WmJDBCAdapter package startup services.
  4. Restart the IS (If your repository is a database).
  5. Make sure the minimum connection pool setting on the JDBC Connection is set to 0.
  6. Work with the database team to run the sql profiler (or any other debugging tool) and see what exactly is happening between the calls.


I question if the JDBC Adapter>Connections is a true reflection of the connectivity to the DB. I’m thinking what it’s saying is if a connection is there, connect to it. Not an actual statue of the connection. We are working through some of that now with poor results.

That page is the configuration, not the status. That page defines the parameters used to make connections and the size/configuration of the connection pool.

The run-time status of a pool and the connections is not available with out-of-the-box Administrator pages (unless 8.x has added something–someone chime in with info if it has).

I have an IS 8.x but it still uses JDBC Adapter 6.5 and I do not see any changes in the Connection settings page that will provide a run-time status of a pool.