IS - Stored Procedure call won't work

Hello Everyone.

I’m trying to call a stored procedure in my Oracle 12g database using the “StoredProcedureWithSignature”.

This procedure puts some data in “IMP_RESULT” table.

If I call the stored procedure directly with pure SQL using DBeaver it works and it puts data correcly in “IMP_RESULT”.

If I run using the flow service, it doesn’t give any error, but the “IMP_RESULT” table isn’t filled with anything.

Should I configure anything else before calling a procedure in my flow service?

I already checked and debugged: The procedure parameters are passing as it should by Integration Server.

Thank you


Ideally you don’t have to configure anything else before calling procedure. As you said, service execution doesn’t give out any error, I would recommend you to inspect the values of procedure parameters when it has been invoked from webMethods either by storing parameter values in a temp table or logging them to console…

You can post your adapter service screen shots and stored procedure here to help you better.


Thanks @maah.

I managed to finally call the procedure by creating a CustomSQL adapter with the SQL Procedure Call query, and it worked!

I don’t know why, but with “StoredProcedureWithSignature” the procedure simply isn’t called as it should. You can check the images below:

With only works with the following:

Hi @Renan_Lopes1,

Could try by just providing Expression values for only PD_DT_INI and PD_DT_FIM and other parameters leave Expression with default value (?) ?