IS is not starting

Hi,
While working with ACLs,suddenly I denied access for everybody.After that I started IS and the following error was coming.
“No listening ports were available. Shutting down server” and the server goes shutting down.
Anybody could help me urgently.

Thanx in advance.

Renuka tell me first that which OS are you using. The easiest thing you can do is make a backup of the config folder which is in WM_IS_dir/IntegrationServer/config directory and delete it then start the server.(server.sh if you are using unix and server.bat if you are using windows).
But remember this will make the settings to the default i.e your server will start on the 5555 port. Later on you can add the desired port and make it primary port(make sure you set the access allow by default) and again start IS administrator with the new port no. and after that you can disable the old port which is 5555 and then delete it.
PS : Make sure you don’t have any IS running on the same box with the 5555 port.

Hi TAZ,

Thanx for giving me that solution.Now it’s working.

Thank you,
renuka

Glad it worked out…

hi TAZ,

Your answer resolved the problem, but i have some pecular problem, when i got the same problem like renuka i uninstalled the IS and reinstalled it but still i am getting same problem, When i uninstall the Webmethods does it removes the all the components or not ?

Thanks
Srinivas

srinivaswebm,Talha,renuka,
Next time if you mess up your ports.
Restart the IS with : server.bat -port ABCD
where ABCD can be an unbound ( unused) port.
Keep in mind that this will override all the previous port entries in your configuration files.
As per your question Srinivaswebm:
TAZ/Talha asked renuka to shutdown her IS, backup her config directory and delete the directory and start the IS.That recreates the config directory.TAZ/Talha didnt ask her to uninstall the IS.
Yes, make sure your IS is shutdown before you uninstall your webmethods components. This “might” cause leave you with renegade ports that wouldnt unbind.Make sure you select all the components.
Scooby !

Hi All

I had the same problem while setting my IDE…I got the same error and tried all the possible solutions from Advantage and WMUsers but i couldnot fix it …actually there are some problems with configuration files that I got with my IDE…WMHome/IntegrationServer/Config .
so I backedup them and copied the config file of IS that is running to WM/IS/config and started the IS …Finally it worked …I went through this step as it is Integrated Environment

Jesan

with IS 6.5 you can start the server in safemode and try to investigate.

PRY

That is indeed one of my favourite option of 6.5 that you can start the IS in safe mode…